All users were logged out of Bugzilla on October 13th, 2018

Queued downloads can be given identical filenames, resulting in overwriting

VERIFIED DUPLICATE of bug 301328

Status

()

--
major
VERIFIED DUPLICATE of bug 301328
10 years ago
9 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

({dataloss})

Trunk
x86
Mac OS X
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

10 years ago
Yesterday, I alt+clicked a bunch of links to various files named 001.mpg, and Firefox decided to save the last five all as 001(2).mpg before any of those five actually started downloading.  When they did start downloading, four of them got clobbered.

Mac, trunk, non-debug

Comment 1

10 years ago
From my memory of the code, this is definately possible...

We probably should resolve conflicts as they are started (or stuff a placeholder file for pending DLs), rather than on first demand.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think the UI doesn't show the right filename, but I thought we didn't overwrite.  I could be wrong though...

Comment 3

9 years ago
The files are correctly renamed on the filesystem, but the UI shows the "original" filename. When downloading multiple files of the same name (report.xls for example) you get multiple entries in the download manager for report.xls, and on disk, get report.xls, report-1.xls, report-2.xls etc. 

Unfortunately, clicking on any of the "report.xls" entries in the download manager just opens the first download, and it is impossible to open the others by clicking on the entries in the download manager.

Possible solution: instead of listing the files by the original name in the download manager, list them by the actual filename on disk...

Updated

9 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false
Whiteboard: DUPEME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 301328

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.