[x64 only] Newly downloaded POP mail inaccessible

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: Mike Cowperthwaite, Unassigned)

Tracking

({64bit})

Trunk
x86
Windows Server 2003
64bit
Bug Flags:
blocking-thunderbird3.0b1 -
blocking-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
TB Gecko/20081005 Shredder/3.0b1pre
Also saw this with 0918.

I'm not sure of the exact steps to reproduce.  I see this problem only when TB is running on my home system: dual-core Athlon, Windows X64 (64-bit XP).  Running on my system at work, a single-core Intel processor with 32-bit XP, I have not seen this problem.  (I'm running a 32-bit version of TB, of course; there are 64-bit builds available out there, but they're not on the trunk.)

The symptom is: new mail arrives.  I click on one of the new items shown in the thread pane, and the message doesn't show in the message pane.  (The message is marked as read, however.)  If I double-click on the item, a blank message window (no envelope or message body) opens up.  I cannot delete the item with either the <del> key or the context menu, nor can I mark it as junk.  However, I can change the tags, star, and as-read status.  Changing the status to Read doesn't result in a change the X-Mozilla-Status headers in the stored version of the file, until after the program is restarted; but the item does go bold in the thread pane.

Older items don't exhibit the problem.  If I exit the program and restart, the new items are now accessible.

This occurs for mail in my POP account, and also for RSS items.
(Reporter)

Comment 1

9 years ago
I just opened bug 461713 which is somewhat similar in its behavior, but easier to reproduce.  I haven't yet determined if that problem is also specific to X64.
Flags: blocking-thunderbird3.0b1?
> dual-core Athlon, Windows X64 (64-bit XP)

Many problems due to skew of TSC(processor Time Stamp Counter) when multi-Core/CPU & ACPI=on are already known.
Example of Thunderbird case; 
  Bug 307527 : Tb bypassed problem by use of timeGetTime(). 
               Other than TSC is used when timeGetTime of 32-bit MS Win-XP.
               I don't know about timer usage for timeGetTime by 64-bit MS Win.
See MS KB articles pointed in Bug 307527.
> http://support.microsoft.com/default.aspx?scid=KB;EN-US;Q274323
> http://support.microsoft.com/kb/Q821893 
> http://support.microsoft.com/kb/Q835730 
> http://support.microsoft.com/kb/Q896256
See also Bu 363258 Comment #36 and document pointed by it, for phenomenon of "leap of Performance counter value".
And, at least kb/Q896256 is applicable to 64-bit MS Win.
> APPLIES TO
> • Microsoft Windows Server 2003, Standard x64 Edition
> • Microsoft Windows Server 2003, Enterprise x64 Edition
>(snip)

If above is cause, following can be a workaround.
 (1) Set CPU affinity, and use single CPU only
 (2) Disable ACPI (lowering of clock rate for power saving)
 (3) /usepmtimer (use PowerManagement Timer as system clock instead of TSC)
 (4) Apply Hot fix, if hot fix for above is not applied yet
Problem caused by skew of TSC?
Sorry for wrong link. See also Bug 363258 Comment #36.

Comment 4

9 years ago
Do you see it with 2.0 as well?
Summary: Newly downloaded POP mail inaccessible → [x64 only] Newly downloaded POP mail inaccessible
(Reporter)

Comment 5

9 years ago
No; I'm using 2.0.0.16 with no problems.  I'm using a recent shredder build on my XP (32) system at work and that's working fine as well.

Updated

9 years ago
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3.0b1?
Flags: blocking-thunderbird3.0b1-
If it's x64 only, I don't think it blocks.
Flags: blocking-thunderbird3? → blocking-thunderbird3-
(Reporter)

Comment 7

9 years ago
Bienvenu suggested that this bug might have been cleared up on current trunk builds, but I downloaded yesterday's 3.0b3pre and the problem manifested pretty much right away.  Perhaps the difference is in the CPU (per comment 2) or perhaps the specific OS; mine is XP/64, David said he was using Vista/64.
(Reporter)

Comment 8

9 years ago
Wayne Mery pointed me to 64-bit builds at 
  http://wiki.mozilla-x86-64.com/Thunderbird:Download

I tried running the latest available there -- 1.9.1b3pre, Gecko/20090305, Shredder/3.0b2 -- and I still see this symptom.  I suspect that the problems WADA described in comment 2 are my issue.  I found a further MSKB URL that may be more pertinent:
  http://support.microsoft.com/kb/895980

For what it's worth, I see that my X64 entry in boot.ini does have the 
/usepmtimer switch; and I have all available MS hotfixes in place.  I'll check back in after trying that updated CPU driver pointed to by that article.

Changing the CPU affinity -- if in fact that would solve the problem -- would need to be done programmatically, I think; I don't see an option in Process Explorer for changing that at run time.

I'm not going to turn off ACPI.  It may be worth mentioning that I frequently suspend my system, overnight and/or while I'm at work.

The 32-bit version of 2.0.0.21 (now) is still performing fine, but of course I'm losing out on the various improvements in the trunk.
(Reporter)

Comment 9

9 years ago
Followup: when I tried to install that new driver from AMD, the setup program asked me if I wanted to REMOVE the feature -- so, I guess I already have it installed.  (It's not clear that there is anything that gets installed beyond adding the switch to boot.ini.)
any further theories on possible tie in to bug 461713?
Keywords: 64bit
(Reporter)

Comment 11

8 years ago
(In reply to comment #10)
> any further theories on possible tie in to bug 461713?

I think both bugs relate to some problem with reading/writing an mbox file.

My mail provider has started offering IMAP, so I've switched over and therefore I'm able to run TB3 on my x64 system now without constantly restarting.  But I have a filter that moves bugmail into a local folder, and more than half the time, when I go to examine that new mail, I can't read it until I restart.

I know that this a pretty minor issue given the tiny number of users running 64-bit Windows on AMD processors.  There are plenty of changes in TB3 that I do not like, and plenty of regressions that I'm noticing, but this is the one that keeps me annoyed.  I don't know if I'm annoyed enough yet to switch to a different client (my new IMAP server is Zimbra-based, and the web client is fairly slick), but that option is on my mind more and more.
(Reporter)

Comment 12

8 years ago
Contrary to comment 0, I haven't seen this symptom with RSS feeds since I started using TB3 regularly a week ago.

I've only been running the 32-bit version this past week.  I've just installed the latest 64-bit build and will report back after working with it for a while.
(In reply to comment #11)
> have a filter that moves bugmail into a local folder, and more than half the
> time, when I go to examine that new mail, I can't read it until I restart.

this sounds like another existing bug report. (but I can't find it)

perhaps also related to Bug 586978?  (but that's not the bug I'm trying to recall)
Blocks: 461713
Mike, can you post your results?

(In reply to Mike Cowperthwaite from comment #12)
> I've only been running the 32-bit version this past week.  I've just
> installed the latest 64-bit build and will report back after working with it
> for a while.
(Reporter)

Comment 15

6 years ago
I don't remember what happened with the 64-bit version.  I'm not receiving any POP mail any longer.  I don't remember the last time I saw this problem with an RSS feed, but not lately.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.