TM: Stack water level is off by +1 in getTop

RESOLVED FIXED

Status

()

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: gal, Assigned: gal)

Tracking

unspecified
x86
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
getTop() should return sp, but it return sp+1. However, fixing this exposes a bug in JSOP_CALLPROP where the tracker is update early (stack(0)) and afterwards we take a snapshot. If that snapshot fails the wrong value is written back.
(Assignee)

Comment 1

10 years ago
Created attachment 342753 [details] [diff] [review]
patch
Attachment #342753 - Flags: review?(danderson)
Attachment #342753 - Flags: review?(danderson) → review+
(Assignee)

Comment 2

10 years ago
http://hg.mozilla.org/tracemonkey/rev/186b4ce768ec
(Assignee)

Comment 3

10 years ago
This patch fixes the redundant comparisons at the end of loops that vlad pointed out a while ago. This might also explain some performance regressions in NJ2 since the underlying comparison code changed.
(Assignee)

Updated

10 years ago
Blocks: 457786
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Flags: in-testsuite-
Flags: in-litmus-

Updated

10 years ago
Depends on: 459630
You need to log in before you can comment on or make changes to this bug.