no warning when quitting with downloads in progress while the download manager is closed

UNCONFIRMED
Unassigned

Status

()

Toolkit
Downloads API
--
major
UNCONFIRMED
9 years ago
4 years ago

People

(Reporter: dresiobi, Unassigned)

Tracking

(Blocks: 1 bug, {dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20120615])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.0.3) Gecko/2008092700 SUSE/3.0.3-2.2 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.9.0.3) Gecko/2008092700 SUSE/3.0.3-2.2 Firefox/3.0.3

Firefox 3.0.3 does not issue a warning on quitting with active downloads. As not all servers support resuming, this may possibly lead to broken downloads.

If firefox asks for confirmation when quitting with multiple tabs available, it would make sense to ask for confirmation with active downloads.

Reproducible: Always

Steps to Reproduce:
1. Download a large file.
2. Close in-built download manager window.
3. Quit firefox while the download is in progress - no warning is issued.


Expected Results:  
The browser should notify the user of the download(s) in progress, leaving them the choice to quit or not.

Comment 1

9 years ago
Occurs on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2 as well.
It should warn you if the downloads are not resumeable (bug 414161 )

Comment 3

7 years ago
The download window should not close on exit of firefox main. This is a bug I have reported yesterday and cannot find anymore. Are people shooting down valid bugs here?

Comment 4

7 years ago
(In reply to comment #3)
> The download window should not close on exit of firefox main. This is a bug I
> have reported yesterday and cannot find anymore. Are people shooting down valid
> bugs here?

Never mind, found.

(bug 590104)

Updated

7 years ago
Version: unspecified → 3.0 Branch

Comment 5

6 years ago
Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101 Firefox/6.0

I can also reproduce as well.

Updated

6 years ago
Version: 3.0 Branch → 3.6 Branch

Updated

6 years ago
Duplicate of this bug: 546511

Updated

6 years ago
Duplicate of this bug: 528768

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Summary: no warning when quitting with downloads in progress → no warning when quitting with downloads in progress while the download manager is closed
Whiteboard: [testday-20120615]
Duplicate of bug: 586865

Updated

6 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

6 years ago
Duplicate of this bug: 586865

Updated

6 years ago
Duplicate of this bug: 644536

Comment 11

6 years ago
Bug 644536 has a good description of the issue.

Bug 741312 is about the lack of warning in the new Downloads Panel.

Updated

6 years ago
Keywords: dataloss

Updated

6 years ago
Component: General → Downloads Panel
QA Contact: general → downloads.panel
I find this bug very annoying. It's a severe usability problem. If I am not mistaken, once (maybe till FX 3.0?) there was a warning appearing when a download was active upon exit in case you had forgotten. Why had it been removed? 

Confirmed on Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0.1
the downloads panel didn't even exist when this bug was filed, moving.
Component: Downloads Panel → Download Manager
Product: Firefox → Toolkit
Version: 3.6 Branch → unspecified
Blocks: 741312
[Confirm] This annoying (regression) bug is still present on Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0
You need to log in before you can comment on or make changes to this bug.