Places autocomplete results contain incorrect search string

RESOLVED FIXED

Status

()

Toolkit
Places
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
From nsIAutoCompleteResult.idl:
 /**
  * The original search string
  */
 readonly attribute AString searchString;

But the result returned from Places autocomplete provides a modified string.

This affects xpfe autocomplete because it sanity-checks the string. Note that both Mork-based histories did return the original string as advertised.
(Assignee)

Comment 1

9 years ago
Created attachment 342785 [details] [diff] [review]
Proposed patch
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #342785 - Flags: review?(sdwilsh)
Comment on attachment 342785 [details] [diff] [review]
Proposed patch

Yes, this makes sense.  Edward should take a look at this too.
Attachment #342785 - Flags: review?(sdwilsh)
Attachment #342785 - Flags: review?(edilee)
Attachment #342785 - Flags: review+

Comment 3

9 years ago
Comment on attachment 342785 [details] [diff] [review]
Proposed patch

r=Mardak

Apparently the autocomplete feedback and UI just asks the controller for the search string instead of poking at the AutoCompleteResult.
Attachment #342785 - Flags: review?(edilee) → review+
(Assignee)

Comment 4

9 years ago
Pushed changeset 1e58e56a8234 to mozilla-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.