`Mozilla Accessibility' section on mozilla.org

RESOLVED FIXED

Status

www.mozilla.org
General
--
enhancement
RESOLVED FIXED
18 years ago
5 years ago

People

(Reporter: John Dobbins, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Mozilla has little to offer for challenged people who need special features.
IMHO this is as bad as ignoring I18N. Since most people don't need or want these
features, I purpose that Mozilla.org add an Acessibility page where people with
special needs can download patches that will add features that address these
needs. This page should have a link from the Mozilla home page so it's easy to find.

The first item for this page would be a go button. The software that blind and
paralized people use requires this feature. See bug 30797.

Another item would be a skin with high contrast and large fonts for people with
limited sight.

Comment 1

18 years ago
2 comments.



First, the idea of an accessibility page is one mozilla.org staff can address.  

I'm reassigning this bug to Dawn our webmaster for this.



The bigger question, implementing features that enhance accessibility is not 

something mozilla.org staff can address, we need contributors to develop and 

contribute these features.  So we can't do much on the underlying issue.  

Assignee: mitchell → endico
(Reporter)

Comment 2

18 years ago
I'm allready working on point 2. Dawn I added two patches to bug 30797. They are 
navigator.css for the Modern and Classic skins. They implement the go button. If 
you can include a link for downloading them along with instructions where to 
copy them to, you will be able to start the accessibility page with some 
patches. Also when you do this, It would be a good idea to change the 
resoulation of bug 30797 from won't fix to fixed, and add a comment explaining 
the patches can be downloaded from the accessibility page.

Once this page is implemented I'll file a RFE bug for a High Contrast skin to 
include on the page. I'm allready researching what is needed for this skin.

Comment 3

18 years ago
John, is this a dup of bug 24413? If not, what things should Mozilla supply 
which aren't covered by the W3C User Agent Accessibility Guidelines?
(Reporter)

Comment 4

18 years ago
First, I hope this page makes Mozilla developers more aware of the issues raised 
by bug 24413. People who aren't challenged tend not to think of these issues, I 
know I wasn't untill I stumbled accross bug 30797 while looking at the help 
wanted bugs. Looking at bug 24413 I see 15 bugs it depends on. 3 of these were 
fixed for reasons other than accessibility. bug 19259 has been verified as later 
and commented won't be in Mozilla 1.0. Of the remaining 11, 3 are set to future 
milestone, one of which, bug 959, was commented "I think we'll have to live 
without this in current release, -> Future" when the milestone was set. 1 is set 
for M18, for reasons not related to accessibility. The rest have no milestone 
set. Before I ran accross bug 30797 it was resolved won't fix. Accessibility is 
being ignored.

Second, since at least 2 of these bugs won't be fixed for Mozilla 1.0, It won't 
be fully complient with the W3C accessibility guidelines. This will provide a 
place for adding this support after 1.0 is released. The challenged souldn't 
have to wait for Mozilla 2.0 to get the features they need.

Third, the guidelines should be considered the minimum support that Mozilla 
should offer the challenged. The only reason not to offer full support for all 
challenged people is that Mozilla would be bigger than Netscape Communicator is 
today (NOT acceptible). A series of patches would allow people to select the 
features they need without turning Mozilla into a bloated 25M download. 
Application size is an aspect of accessibility that is often overlooked. Many of 
the challenged are on a fixed income and can't afford new computers. Smaller aps 
run better on the older machines they have. Keeping Mozilla small enough to run 
on these computers is an accessibility feature. Patches are a way of doing this.

Eventually I would like to see an Accessibility Page that uses Smart Update. 
Then the challenged can go to it and add the features they need without the 
hassle of manually installing the patches. A wide range of assessibility 
features and Smart Update would make chosing Mozilla a no-brainer for the 
challenged. 

Matthew, Many aspects of the W3C guidelines are a comprimise between what is 
acceptible to the general public and the needs of the challenged. A good example 
would be a high contrast 2 color skin with large icons. Most users would find it 
unappealing to look at, and would think the toolbar took up too much room. A 
person with limited eyesight would consider it a godsend. This page would be a 
place for features that exceed the W3C guidelines in ways the average user would 
find unaceptible.

Comment 5

18 years ago
Ok. Two points:
* Mozilla has the potential to provide better accessibility of Web content than
  any other popular browser, because it has better HTML support overall (and
  quite a bit of HTML 4.0 was designed with accessibility in mind).
* Mozilla has the potential to provide worse accessibility of interface than any
  other browser, because its interface doesn't use native controls (and many
  accessibility aids rely on the use of native controls).

I agree that an Accessibility section on mozilla.org would be a good idea. This 
would assume a rejigging of the mozilla.org site to be more end-user-friendly 
in general, though, and that may not happen for a while. (Dawn, I'd like to 
help out when you do this.)

Resummarizing, so that this doesn't get marked as a dup of bug 24413.
QA Contact: mpt
Summary: Accessibility for the Challenged → `Mozilla Accessibility' section on mozilla.org

Comment 6

17 years ago
http://access-mozilla.sourceforge.net
and
www.mozilla.org/projects/ui/accessibility

Should the two have different roles?
Perhaps the sourceforge page should be for new people learning about it, and the
mozilla project page should be for the hard facts and data.

Dawn, should we point to the new project page from somewhere?
Status: NEW → ASSIGNED

Comment 7

17 years ago
they should either have two roles or one should go away. Your suggestion
on how to divide them up sounds good. Add a section for
www.mozilla.org/projects/ui/accessibility in projects/index.html
depending on how you word it you might want to add a link to the
sourceforge page too.
Assignee: endico → mozilla.webmaster
Status: ASSIGNED → NEW
Component: Miscellaneous → webmaster@mozilla.org
Priority: P3 → --
QA Contact: mpt → danielwang

Comment 8

13 years ago
We currently have http://www.mozilla.org/access
Assignee: www-mozilla-org → nobody
QA Contact: danielwang → www-mozilla-org

Comment 9

11 years ago
(In reply to comment #0)
> Mozilla.org add an Acessibility page

Done. http://www.mozilla.org/access/

> where people with
> special needs can download patches that will add features that address these
> needs. 

"Firefox 2 now has help topics (From the menubar: ? > Help Contents F1 > Accessibility Features) which describe any special features and keyboard shortcuts designed to help users with disabilities."
Information for Users
http://www.mozilla.org/access/users

Accessibility Features in Firefox
http://www.mozilla.org/access/features


> Another item would be a skin with high contrast and large fonts 
> for people with
> limited sight.

May I suggest on this precise issue the excellent webpage:
http://www.accessfirefox.com/Firefox_Accessibility_Themes.php
which showcases "specially designed themes for those with low vision":
- several High Constrast themes, 
- several themes with Big Icons, 
- some extra large and bright icons themes
- some extra large icons and extra large bold text

The accessibility themes for Firefox page (http://www.accessfirefox.com/Firefox_Accessibility_Themes.php) and the whole accessfirefox.com website should be listed at
http://www.mozilla.org/access/users

Comment 10

11 years ago
I have updated the page
http://www.mozilla.org/access/users
to meet the request about an high contrast and large 
fonts skin for people with
limited sight.

Is it ok to resolve this bug as FIXED?

Comment 11

11 years ago
I have also mentioned the accessibility themes for Firefox for people with low vision at
Accessibility Features in Firefox
Customize Your Experience!
http://www.mozilla.org/access/features.html#customize

Comment 12

11 years ago
Hello all,

I'm RESOLVING this bug as FIXED since most/all of the points raised by the original reporter, John Dobbins, have been addressed satisfactorily.

You may REOPEN (with providing explanations) if you think this is wrong.

Cheers
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Product: mozilla.org → Websites
(Assignee)

Updated

5 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.