Misleading message if profile folder does not exist

RESOLVED DUPLICATE of bug 278860

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 278860
10 years ago
10 years ago

People

(Reporter: Frank-Ralph Reiser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081012 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081012 Minefield/3.1b2pre

I have a profile on a usb stick, that's not always mounted.
If I try to start firefox using
 firefox -P usbstick -no-remote
it tells me
 "Firefox is already running, but is not responding. [..]"

This message is simply misleading - there is no firefox instance running, just the profile folder specified in the profile.ini doesn't exist.



Reproducible: Always

Steps to Reproduce:
1. create a profile "usbstick" with a path that isn't relative
2. remove the folder,  make the parent directory of that folder not-writable (or delete this as well) - or simply unmount the volume
3. start firefox specifying that profile like firefox -P usbstick -no-remote
Actual Results:  
Firefox show a dialog stating 
 "Firefox is already running, but is not responding. [..]"

Expected Results:  
Firefox should tell me something like 
"The profile folder at ... couldn't be found. Creating that folder anew failed. Please check your profile.ini and your profile folder."
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 278860
You need to log in before you can comment on or make changes to this bug.