All users were logged out of Bugzilla on October 13th, 2018

Password manager fails at second trial

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: nuesken, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

Whenever Firefox 3.03 attempts to fill in a password it does so properly at first trial.  When a further fill in (no matter whether it's the same page again or another) occurs, nothing is filled in or given as a choice.
When I go the password list (Tools->Options->Saved passwords) this list is shown though only partially the first time, but the second time it is empty.

I did resave signons3.txt (and signons2.txt) as UTF-8 several times, but this doesn't change anything.

Reproducible: Always

Steps to Reproduce:
1. Call list of saved passwords.
2. Call list of saved passwords again.

Actual Results:  
After 1. a partial list, after 2. an empty list.

Expected Results:  
Complete list both times.

Error occurs since upgrade to 3.03 (in German).

PS: I tried to search similar bugs, yet it seems that either this has not yet been reported or my keywords were bad.

Comment 1

10 years ago
Exactly the same behavior here. Firefox 3.0.3 German.

Comment 2

10 years ago
This also occurs for me. (English)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

Tried with "safe-mode": still occurs.
(Reporter)

Comment 3

9 years ago
Bug does not occur in Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 any more. :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.