Closed Bug 459751 Opened 11 years ago Closed 11 years ago

about:sessionrestore switches button placement

Categories

(Firefox :: Theme, defect)

All
macOS
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 3.1b2

People

(Reporter: cmtalbert, Assigned: mstange)

References

Details

Attachments

(1 file)

This is one of those issues that we are going to get flamed on: the new about:sessionrestore dialog switches the location of the new/restore buttons.  While making UI is all about breaking cartons of eggs, I really think this is one carton we are breaking for no obvious benefit.

In the old dialog:
|------------------------------|
|                              |
| <text><text><text>           |
|                              |
| New Session   Restore Session|
|-------------------------------

In the new dialog we get:
|------------------------------|
|                              |
| <nifty new tab list>         |
|                              |
| Restore Session   New Session|
|-------------------------------

So, the issue here is pretty obvious.  We've trained people to click one or the other of these buttons based on their usual preference (Mine is to always restore the last session).  Now, when they click on their usual button, the opposite action will happen.  I don't see any clear UI win on this shift whatsoever; it just looks like we are in progress with this dialog.

== Expected ==
The dialog can look new shiny and beautiful but keep "New Session" on the left and "Restore Session" on the right.

== Actual ==
The buttons are backwards from the previous version.
Flags: wanted-firefox3.1?
Clint, just FYI: about:sessionrestore has never been tested on OS X. What you see is thus a state in urgent need of some initial theme love and not an intentional state of things.
Blocks: 459546
This is BTW already fixed on Linux (and is correct on Windows).
Component: Session Restore → Theme
OS: All → Mac OS X
QA Contact: session.restore → theme
(In reply to comment #1)
> Clint, just FYI: about:sessionrestore has never been tested on OS X. What you
> see is thus a state in urgent need of some initial theme love and not an
> intentional state of things.
Oh Good!  I'm very glad to hear this.  I haven't crashed yet on Windows (wow, I never thought I'd type that sentence) so I haven't seen it there yet.

I'm looking forward to using the dialog after you (or whoever's doing the work) is finished with it.
(In reply to comment #3)
> Oh Good!  I'm very glad to hear this.  I haven't crashed yet on Windows (wow, I
> never thought I'd type that sentence) so I haven't seen it there yet.

FWIW, you can terminate Firefox using your OS process manager and restart it.  The first time it thinks it had a first crash and restores the session silently.  The second time the new about:sessionrestore page is shown.
(In reply to comment #4)
> (In reply to comment #3)
> > Oh Good!  I'm very glad to hear this.  I haven't crashed yet on Windows (wow, I
> > never thought I'd type that sentence) so I haven't seen it there yet.
> 
> FWIW, you can terminate Firefox using your OS process manager and restart it. 
> The first time it thinks it had a first crash and restores the session
> silently.  The second time the new about:sessionrestore page is shown.
Is this by design? I noticed that too, but I hadn't filed a bug on it.  When I found this issue, I was debugging a reproducible crash.  The first crash no dialog was displayed, the second crash the dialog was displayed, and then I misclicked the reversed buttons and never found out which tab was causing the crash.

Thinking of it now, it does seem like a good design UX to assume that the first "crash" you should restore silently.  If it's not by design, then I'll file a bug to keep that behavior ;-)
(In reply to comment #5)
> Thinking of it now, it does seem like a good design UX to assume that the first
> "crash" you should restore silently.  If it's not by design, then I'll file a
> bug to keep that behavior ;-)

It is by design, see attachment 336774 [details] and also bug 448976.
> then I misclicked the reversed buttons and never found out which tab was
> causing the crash.

Bonus tip: When you click the wrong button, you can always go Back to the Restore page through either the Back button (as we just load your homepage over it) or by entering about:sessionrestore in the address bar. Dataloss really isn't intended... ;-)
Assignee: nobody → dao
Attached patch patch v1Splinter Review
Like this?
Assignee: dao → mstange
Status: NEW → ASSIGNED
Attachment #344884 - Flags: review?(zeniko)
Comment on attachment 344884 [details] [diff] [review]
patch v1

>+  -moz-margin-start: 80px;

Please add a comment as to where these 80px come from.

And somebody more familiar with OS X/Gnome will have to judge whether these buttons shouldn't rather be right-aligned so that the default button continues to reside at one of the page's side. We can do that after Beta 2, though.
Attachment #344884 - Flags: review?(zeniko) → review+
pushed: http://hg.mozilla.org/mozilla-central/rev/3dbb3095c8a9
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1b2
Flags: wanted-firefox3.1?
verified fixed using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081030 Minefield/3.1b2pre
Status: RESOLVED → VERIFIED
Depends on: 462632
You need to log in before you can comment on or make changes to this bug.