Printing to postscript only prints last page, with 'font-family: helvetica' (though print-to-PDF works fine)

RESOLVED INVALID

Status

()

RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

10 years ago
Created attachment 342993 [details]
testcase 1

STEPS TO REPRODUCE:
 1. Load testcase 1 (attached)
 2. Ctrl-P to bring up GTK print dialog
 3. Select "Print to File".  ("Postscript" should already be selected, to the lower-right)
 4. Click "Print", & then view the output file.

ACTUAL RESULTS:
 The outputted postscript file is one page long -- it's just the final page.

EXPECTED RESULTS:
 The outputted postscript file should have all pages (about 5 pages total, in testcase 1)

VERSION INFO:
* Browser: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081013 Minefield/3.1b2pre
* OS: Ubuntu 8.10 beta (updated as of this morning)
* Postscript viewer: Evince, version 2.24.0-0ubuntu2

NOTES:
 - If I remove the "font-family" style rule, I get expected output.
 - If I print to PDF instead of to PS, I get expected output.
Flags: blocking1.9.1?
(Reporter)

Comment 1

10 years ago
Created attachment 342994 [details]
testcase 1 printed to PS (BROKEN)
(Reporter)

Comment 2

10 years ago
Created attachment 342995 [details]
testcase 1 printed to PDF (WORKING)
(Reporter)

Comment 3

10 years ago
I see this in Firefox 3.0.3, as well.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092515 Ubuntu/8.10 (intrepid) Firefox/3.0.3
(Reporter)

Comment 4

10 years ago
D'oh... Looks like this is a bug in Ubuntu 8.10's version of Evince (the PS viewer), not in Firefox.

I just tried viewing the "broken" postscript file (attachment 342994 [details]) using Evince version 2.22.1.1-0ubuntu1 in the older Ubuntu 8.04, and it's fine there -- I see all 5 pages.
 --> INVALID.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

10 years ago
FWIW: I filed http://bugzilla.gnome.org/show_bug.cgi?id=556216 on this issue in Evince.

Updated

10 years ago
Flags: blocking1.9.1?
You need to log in before you can comment on or make changes to this bug.