Reviews display page is a 404

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
--
critical
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: stephend, Assigned: lorchard)

Tracking

({regression})

Details

(URL)

(Reporter)

Description

9 years ago
Reviews are broken

Steps to Reproduce:

1. Load https://preview.addons.mozilla.org/en-US/firefox/addon/2373
2. Click on "See all reviews (1)" (https://preview.addons.mozilla.org/en-US/firefox/reviews/display/2373)
(Reporter)

Updated

9 years ago
Summary: Reviews are broken → Reviews display page is a 404
"No Database table for model ReviewsModerationFlag (expected "reviews_moderation_flags"), create it first."

Les: I think, you need to have IT execute your SQL changes on preview :)
Assignee: nobody → lorchard
(Reporter)

Comment 2

9 years ago
Les actually mentioned it needed doing in https://bugzilla.mozilla.org/show_bug.cgi?id=435156#c37, but I filed this because I wasn't sure if we'd tag the changes as they are presently, since code freeze is tonight (but tagging comes later, so I might've jumped the gun, sorry).
(Assignee)

Updated

9 years ago
Depends on: 459842
(Assignee)

Comment 3

9 years ago
Bug 459842 filed to get DB changes for preview executed.

https://wiki.mozilla.org/Update:Developers/Database_Changes#4.0.3
No longer depends on: 459842
(Assignee)

Updated

9 years ago
Depends on: 459842
(Assignee)

Comment 4

9 years ago
I believe this is working now, after a DB update and a kicking of cake
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

9 years ago
Verified FIXED; checked 5 random add-on review pages.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.