location bar not focused in new tab while in full screen

RESOLVED DUPLICATE of bug 439774

Status

()

--
minor
RESOLVED DUPLICATE of bug 439774
10 years ago
8 years ago

People

(Reporter: azimout, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008101315 Ubuntu/8.10 (intrepid) Firefox/3.0.3

pressing ctrl+t while in full-screen opens a new tab, but the focus is not on the location bar. ctrl-l brings the focus where it should be. this is not the case in normal mode (non-full-screen)

Reproducible: Always

Steps to Reproduce:
1.press f11 for full-screen
2.press ctrl+t for a new tab
3.type something
Actual Results:  
nothing was written, because the focus was not in the location bar

Expected Results:  
the focus should be in the location bar, just like outside full-mode

this report was initially filled downstream in ubuntu's launchpad:
https://bugs.launchpad.net/firefox/+bug/215692

Comment 1

10 years ago
I just want to mention explicitly that this is a regression from Firefox 2; you could hit ctrl+t and type URLs and hit enter just fine (even though you couldn't see the URL bar). This was a great boon to my netbook browsing productivity.
If you change browser.fullscreen.autohide to false, do you get the desired behaviour back? http://kb.mozillazine.org/About:config

Comment 3

10 years ago
Hi Ria. That option does not give me that behavior back. It just doesn't hide the tab bar. The bug doesn't have to do with what is shown or not, but whether the keyboard input goes to the hidden location bar or not and allows you to then visit websites. Thanks though!

Comment 4

10 years ago
Just mentionning that it is still present in last Minefield 3.2 build.

Comment 5

10 years ago

Hi,

Just to confirm, this is reproduceable under FF3.x on Linux.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.8) Gecko/2009032608 Firefox/3.0.8. Slackware 12.1

It is highly annoying, if you prefer full-screen mode.
The only workaround is:
F6 (to show the location bar) + TAB (to focus on the text field for the location).

Mike Rooney's first comment doesn't work for me. You can't type in the field unless you hit the key combination I mentioned.

Thanks in advance!

Martin

Comment 6

10 years ago
Also confirming on Linux.  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090407 Shiretoko/3.5b4pre
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

9 years ago
Flags: wanted-firefox3.6?
OS: Linux → All
Version: unspecified → Trunk

Updated

9 years ago
Duplicate of this bug: 500783

Comment 8

9 years ago
Another variant of this bug (reproduced with Firefox 3.5 20090624)
When moving the focus to location bar by clicking into the location bar, "Search bookmarks and history" can be edited, but the entered address is ignored when pressing enter. Only after moving the focus away and back to the location bar, a new address can be entered.
It is only reproducable, if the location bar is hidden when pressing Ctrl+t.

Comment 9

9 years ago
Bug 494373 has a patch, shouldn't this be a duplicate?

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Flags: wanted-firefox3.6?
Resolution: --- → DUPLICATE
Duplicate of bug: 439774

Updated

8 years ago
You need to log in before you can comment on or make changes to this bug.