Vital browser and window controls hidden in full screen mode with certain gui configurations

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: ethana2, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-09-15], URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1) Gecko/20081007 Firefox/3.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b1) Gecko/20081007 Firefox/3.0

My menu bar contains my menu, toolbar buttons, and Awesome Bar, as I feel that any other way of doing it is both a screen real estate travesty and a painful lack of elegance.  The only other bar displayed in my firefox is the tab bar.

When using fullscreen mode, it's entirely hidden, making this mode unusable for me.  The URL is a screen shot of what I see in fullscreen mode.

Reproducible: Always

Steps to Reproduce:
1.customize
2.move everything into the menu bar and uncheck the others
3.enter full screen mode
Actual Results:  
Firefox rendered itself unusable by mouse.
The first time was worse, I didn't know that F11 was the way to exit full screen mode and I was stuck, had to kill firefox.

Expected Results:  
I should be able to set firefox to display the menu bar in full screen mode, and I should be able to put the minimize/restore/close buttons into the menu bar like anything else in customize.

Also, I don't use title bars, I use maximus and window-picker-applet, so if I could have it display its own minimize/restore/close buttons all the time, that would be nice too... but it's not necessary I guess.
(Reporter)

Comment 1

10 years ago
Created attachment 343150 [details]
This is what firefox looks like on my machine when maximized.

This should better illustrate my GUI configuration.
Do you still see this problem using the most recent versions of all components (application, plugins and add-ons)?

If you do not, please close the bug with resolution set to WORKSFORME. If problem was caused by add-on or non-mozilla code please use INVALID resolution.
If you do still see the problem, please comment in the bug.
Whiteboard: [closeme 2010-09-15]
(Reporter)

Comment 3

8 years ago
This issue is still present.
No reply, INCOMPLETE. Please retest with Firefox 3.6.10 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.