Crash when closing a window and Leak Monitor installed [@ JS_GetStringChars]

VERIFIED DUPLICATE of bug 450906

Status

()

--
critical
VERIFIED DUPLICATE of bug 450906
10 years ago
8 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({crash})

1.9.0 Branch
x86
Windows Vista
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Vista incompatibility?], crash signature)

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4pre) Gecko/2008101505 GranParadiso/3.0.4pre (.NET CLR 3.5.30729) ID:2008101505

Firefox crashes when having Leak Monitor 0.4.2 installed and closing a window.

Steps:
1. Install Leak Monitor 0.4.2
2. Start Firefox and open another window
3. Close the new window
=> After some seconds Firefox crashes.

Crash report: bp-2f4f22a3-9ac8-11dd-8edd-001cc45a2c28

0  	js3250.dll  	JS_GetStringChars  	 mozilla/js/src/jsapi.c:5348
1 	leakmon.dll 	leakmon.dll@0x27f5 	
2 	leakmon.dll 	leakmon.dll@0x190a 	
3 	leakmon.dll 	leakmon.dll@0x2099 	
4 	leakmon.dll 	leakmon.dll@0x21ae 	
5 	leakmon.dll 	leakmon.dll@0x2204 	
6 	xul.dll 	nsTimerImpl::Fire 	mozilla/xpcom/threads/nsTimerImpl.cpp:408
7 	xul.dll 	xul.dll@0x7c428f
(Reporter)

Comment 1

10 years ago
The same version of Leak Monitor works on Windows XP and the official release of Firefox 3.0.3. Probably an incompatibility with Windows Vista?
Whiteboard: [Vista incompatibility?]
(Reporter)

Comment 2

10 years ago
Now it looks like a dupe of bug 450906?

ChildEBP RetAddr  
WARNING: Stack unwind information not available. Following frames may be wrong.
0025f3bc 1000190b leakmon!NSGetModule+0x1743
0025f42c 1000209a leakmon!NSGetModule+0x8a2
0025f4a4 100021af leakmon!NSGetModule+0x1031
0025f4e4 10002205 leakmon!NSGetModule+0x1146
0025f520 65a517c3 leakmon!NSGetModule+0x119c
0025f540 65a51691 xul!nsTimerImpl::Fire(void)+0x125 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\xpcom\threads\nstimerimpl.cpp @ 409]
0025f54c 659ae098 xul!nsTimerEvent::Run(void)+0x1f [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\xpcom\threads\nstimerimpl.cpp @ 492]
0025f570 6599970a xul!nsThread::ProcessNextEvent(int mayWait = <Memory access error>, int * result = <Memory access error>)+0x218 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\xpcom\threads\nsthread.cpp @ 511]
0025f588 65b356e8 xul!nsBaseAppShell::Run(void)+0x4a [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\widget\src\xpwidgets\nsbaseappshell.cpp @ 169]
0025f594 65a6edaa xul!nsAppStartup::Run(void)+0x1e [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\toolkit\components\startup\src\nsappstartup.cpp @ 182]
0025f59c 003130a8 xul!XRE_main(int argc = 0, char ** argv = 0x00000a8d, struct nsXREAppData * aAppData = 0x00000000)+0xdb7 [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\toolkit\xre\nsapprunner.cpp @ 3178]
0025f5a0 00000000 0x3130a8
(Reporter)

Comment 3

10 years ago
(In reply to comment #2)
> [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\toolkit\xre\nsapprunner.cpp

Why I get references to trunk while running Gran Paradiso in Windbg?

Comment 4

10 years ago
ask someone from the build team, probably a legacy structure :)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 450906
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED
(In reply to comment #3)
> (In reply to comment #2)
> > [e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\toolkit\xre\nsapprunner.cpp
> 
> Why I get references to trunk while running Gran Paradiso in Windbg?

1.9.0 used to be the trunk, that's just the path on the tinderbox where it's building.
(Reporter)

Comment 6

10 years ago
Ok, thanks Ted!
Crash Signature: [@ JS_GetStringChars]
You need to log in before you can comment on or make changes to this bug.