Migrate tbnewref-win32-tbox and tb-linux-tbox from MoCo to MoMo

RESOLVED FIXED

Status

Mozilla Messaging
Server Operations
--
major
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: catlee, Assigned: phong)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3
Build Identifier: 

Please migrate the tbnewref-win32-tbox VM from MoCo's ESX host to MoMo's

Reproducible: Always
tb-linux-tbox too ?
(Reporter)

Comment 2

10 years ago
yes, tb-linux-tbox too.
Should be a separate bug for tb-linux-tbox IMO.

Comment 4

10 years ago
Phong, is this something you do?
Assignee: server-ops → phong
(In reply to comment #3)
> Should be a separate bug for tb-linux-tbox IMO.

Actually, lets move both of these VMs here in this one bug. Sound reasonable?
Summary: Migrate tbnewref-win32-tbox from MoCo to MoMo → Migrate tbnewref-win32-tbox and tb-linux-tbox from MoCo to MoMo
Sure, works for me too. Since these 2 boxes are VMs, the best thing for me to preserve safety would be for us to schedule some time you can shut them down, then grab the VM images and ship them over to me.

For the linux box, it should be very simple, leaving me with only networking settings to adjust. For the Win32 box, I suspect you'll want to scrub it of licenses, similar to what has been done before when getting me a copy of the win32 ref platform.

Sounds feasible ?

Comment 7

10 years ago
gozer, do you have a destination host/location for these exported files?  That's what we did last time IIRC.
The best is do just like last time around. I'll prep an area on momoadm01 that can recieve the images.

We'll need to schedule downtime while we move those around? Or can you just take a quick snapshot and export that while the VM is still running.

In any case, just lemme know when is convenient, and I'll make sure there is space waiting for the images.

Comment 9

10 years ago
You should setup the space so when I can schedule time, it's already there and I can transfer content to it.  I think my keys should still be on your box?

Updated

10 years ago
Assignee: phong → mrz

Comment 10

10 years ago
Reassign when you have space avaialble.
Assignee: mrz → gozer
Component: Server Operations → Server Operations
Product: mozilla.org → Mozilla Messaging
QA Contact: mrz → server-ops
Space available (87G) here:

momoadm01.sj.mozillamessaging.com:/mnt/scratch/

There is a top-level directory there containing the win32 machine image (momo-win2k3sp2-vc8tool-scrubbed-ref-vm), so just create more top-level directories for the 2 new machine images.
Assignee: gozer → mrz

Comment 12

10 years ago
I need to shutdown this src VM to export it - when can it go offline?
Since we are getting close to running our Beta 1 builds on these boxes, I'd rather wait until Beta 1 shipped.

I'll re-take the bug and reassign back once Beta 1 is out.
Assignee: mrz → gozer
OS: Windows 2000 → All
Hardware: PC → All
Could we do this now ? It'd be one less machine on a very busy ESX cluster.
Yes, we certainly can. Beta 1 went out and we can deal with downtime for the build hosts now.

Coordinate with me on IRC for exact timing, but you can do it whenever I am around. Destination for the images is the same as usual momoadm01:/mnt/scratch/

Comment 16

10 years ago
gozer, shut down those VMs and toss the bug over to moco server-ops and they'll get moved.
Allright, I'll do it on Monday (Dec 15th 2008)
One problem with this, is that once we move these builders *outside* the MoCo network, they won't be able to push updates to aus.mozilla.org, so that's a bit of a problem, until we are running our own AUS server, that is.
Depends on: 477275
Can't tell from the column names on the Thunderbird trees which jobs these two VMs are doing, and therefore if the AUS issue is still live or not. gozer?
Severity: normal → major
Build logs say they did the nightlies for Tb3.0 this morning, and we're only using our own AUS for trunk, not 3.0, so it's still a problem until the bug I don't think is filed, to switch our 1.9.1 builds over to our AUS, gets fixed.
(In reply to comment #19)
> Can't tell from the column names on the Thunderbird trees which jobs these two
> VMs are doing,

Thunderbird3.0:
 - Linux comm-central build
 - Linux comm-central nightly
 - Win2k3 comm-central build
 - Win2k3 comm-central nightly

> and therefore if the AUS issue is still live or not. gozer?

Yes, these are still using aus2.mozilla.org
Depends on: 487629
(In reply to comment #20)
> Build logs say they did the nightlies for Tb3.0 this morning, and we're only
> using our own AUS for trunk, not 3.0, so it's still a problem until the bug I
> don't think is filed, to switch our 1.9.1 builds over to our AUS, gets fixed.

That's correct, there is no bug filed for this change, but there should be one.

Filed bug 487629.
Depends on: 501201
No longer depends on: 501201
Depends on: 501201
Update: They have now been migrated to MoMo hosts, and have no more buildbot duties left.

Only thing left for them is finishing the Thunderbird 3 Beta 3 builds.

Once Beta 3 is released, these can go back to moco.
(In reply to comment #16)
> gozer, shut down those VMs and toss the bug over to moco server-ops and they'll
> get moved.

Done, machines powered off.
Assignee: gozer → server-ops
(Assignee)

Updated

9 years ago
Assignee: server-ops → phong
(Assignee)

Comment 25

9 years ago
is this on cb-vmware01 right now?
They're on the RelEng ESX cluster right now. From comment #23, are they're no longer required at all, and we don't need to move them to MoMo?
(Assignee)

Comment 27

9 years ago
I am pulling them right now to nm-ops02 and then over to MoMo.
(In reply to comment #26)
> They're on the RelEng ESX cluster right now. From comment #23, are they're no
> longer required at all, and we don't need to move them to MoMo?

(In reply to comment #23)
> Update: They have now been migrated to MoMo hosts, and have no more buildbot
> duties left.
> 
> Only thing left for them is finishing the Thunderbird 3 Beta 3 builds.
> 
> Once Beta 3 is released, these can go back to moco.


err... after reading comment#23, comment#26, I'm unclear whats to do here.


Gozer: can you confirm if Phong still needs to do anything here with these VMs, or are you happy with what you already have - and we should just delete the VMs and close this bug?
(Assignee)

Comment 29

9 years ago
phong@momoadm01.sj.mozillamessaging.com:/mnt/scratch/incoming/
(In reply to comment #28)
> (In reply to comment #26)
> > They're on the RelEng ESX cluster right now. From comment #23, are they're no
> > longer required at all, and we don't need to move them to MoMo?
> 
> (In reply to comment #23)
> > Update: They have now been migrated to MoMo hosts, and have no more buildbot
> > duties left.
> > 
> > Only thing left for them is finishing the Thunderbird 3 Beta 3 builds.
> > 
> > Once Beta 3 is released, these can go back to moco.
> 
> err... after reading comment#23, comment#26, I'm unclear whats to do here. 
> 
> Gozer: can you confirm if Phong still needs to do anything here with these VMs,

Like was said before, and sorry if anything caused confusion, I want these copied over so I can archive them on my end. Theorically, I shouldn't need them anymore, but I want to have them around in case I ever do.

So, Phong, if you have exported these, please do copy them over to momoadm01 and that will be that.
(Assignee)

Comment 31

9 years ago
gozer: I'm starting the transfer now.  It's about 70 GB for the 2 VMs.  It should take about 8 hours to finish.  I'll let you know when it's all.
(Assignee)

Comment 32

9 years ago
VM's copied over to momoadm01.sj.mozillamessaging.com:/mnt/scratch/incoming/

Please verify and I can delete the VM's off Build ESX hosts.
(Assignee)

Comment 33

9 years ago
moved and verified.  deleted and removed from inventory.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.