If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Horizontal scrolling when table has position:relative

RESOLVED DUPLICATE of bug 394154

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 394154
9 years ago
9 years ago

People

(Reporter: Andrej Czapszys, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.3) Gecko/2008092510 Ubuntu/8.04 (hardy) Firefox/3.0.3

No matter the actual table dimensions, setting a table's position:relative and shifting to the right results in unexpected horizontal scrolling.

Reproducible: Always

Steps to Reproduce:
1. Put this in your HTML: <table style="position:relative;left:55px" border="1"><tr><td>Content</td></tr></table>
2.
3.
Actual Results:  
Makes the window scroll to the right an extra 55px.

Expected Results:  
Window should not have a scroll bar.
(Reporter)

Comment 1

9 years ago
Created attachment 343276 [details]
example document showing the issue

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 394154
You need to log in before you can comment on or make changes to this bug.