Folder unread count not remembered across sessions

VERIFIED DUPLICATE of bug 18346

Status

MailNews Core
Backend
P3
normal
VERIFIED DUPLICATE of bug 18346
18 years ago
10 years ago

People

(Reporter: Phil Peterson, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using 2000-07-20-08 commercial build on NT

1. Filter bugzilla mail into a folder
2. Quit the app before selecting the folder (app crashes)
3. Run the app
4. bugzilla folder does not show any unread messages until selecting it

Guessing this is a panacea.dat issue, so starting with bienvenu.

Not sure if we're getting a chance to write the unread count before we crash,
but thought I should file the bug anyway.
(Assignee)

Comment 1

18 years ago
marking dup. I've made it so that whenever we commit the .msf database, we also
do an incremental commit of the panacea.dat summary file, which should keep
everything in sync. This will slow down commits a little, but the penalty for
opening a database at startup with Mork is much higher than in 4.x (because we
read in the whole db) so I thought a pay as you go approach was worthwhile.  

*** This bug has been marked as a duplicate of 18346 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 2

18 years ago
Marking verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.