Inline images not forwarding.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: gholmes1936, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_5; en-us) AppleWebKit/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1
Build Identifier: Both v2.0.0.17 and v3.0b1pre

I am not able to forward an email with the images that are in them to other people. Everytime that I try I get messages back saying "Was there supposed to be an image in this?" . In both versions, that I have,  I have tied to make it work with "View>Display Images Inline" checked it still will not forward the images. I found one long way of working around this. First I have to drag all the images from the original email to a folder on my desktop (or wherever). Then I select Forward. When the email to be forwarded comes up I have to drag the images into the text window and then go to the select attachments and find and select the images from the folder that I placed them in earlier.

Then I  went into the Preferences and then to the Advanced tab and then selected the General tab. After it opens I went to the Advanced Configuration Editor. In which I scrolled down to "mail.inline_attachments" and looked at the true or false area of that line. it is set as default>boolean>true. So I don't know what else to do.

Reproducible: Always

Steps to Reproduce:
1. Try to forward an email that has an image embedded in it.
2. Have the addressee replay whether or not the image followed along with the email. Like it did originally
3. Try something  else.
Actual Results:  
Please see the above listed details.

Expected Results:  
Images weren't forwarded along with the email.

Forwarded the images along with the email. I am using only the default themes, etc. No plug-ins or anything else like that.

Comment 1

10 years ago
From your description, I would assume that this is likely bug 307023.
Please check for the following symptoms for a message showing the problem:

(1) The images are part of the message, not attachments, thus should disappear when you select View > Message Body As > Plain Text, regardless of the setting for View > Display Attachments Inline.

(2) When you forward, assuming that you use HTML composition mode, the images are replaced with blank boxes rather than showing the contents of the image, already in the composition window.

(3) When looking at View > Source, find an entry "Content-Type: text/html" which is followed by "Content-Transfer-Encoding: quoted-printable" in the next line or so, this combination would trigger the bug I have in mind (note that there may be multiple "Content-Type:" definitions in a message).

(4) After sending, the copy in your Sent folder lacks any images as well.

If you see a different behavior, we would have to investigate further.
(Reporter)

Comment 2

10 years ago
I don't believe it has anything to do with inline images and HTML mail. I am simply trying to forward an email that has an image in it that came in a regular email. Like someone places a cartoon in an email and sends it to you and you want to forward it. Could be a picture (jpg) or an animated gif also.

I have found that I can go to the "Message" menu and pull down to "Forward As" and then a side pop out window opens with two selections; Inline OR Attachment. Since I have been using this workaround almost all of my forwards that have images in them have seemed to work okay. At lest nobody has said otherwise.

One friend of mine is using Entourage and cannot get animated gif's from me but I suspect that is a problem with her preference settings. As nobody else I sent it to has mentioned any problems.

Comment 3

10 years ago
(In reply to comment #2)
> I don't believe it has anything to do with inline images and HTML mail. I am
> simply trying to forward an email that has an image in it that came in a
> regular email. Like someone places a cartoon in an email and sends it to you
> and you want to forward it. Could be a picture (jpg) or an animated gif also.

If you want to place an image into the message body itself, you need to have HTML composition mode and have to embed those images inline, thus it may quite well be the bug I referred to above. The only other option would be to attach them as regular attachments, regardless of the message format (which you seem to do in your workaround).

Did you perform any of the steps in my comment #1?

Comment 4

10 years ago
George, I'm resolving this WFM based on the information you provided in http://forums.mozillazine.org/viewtopic.php?p=4820075#p4820075 - apparently, it was a configuration issue, since it wasn't clear from comment #2 what you actually did. If the problem persists, please feel free to reopen and add the necessary information.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.