Sumo new search load and performance testing

VERIFIED FIXED in 0.8

Status

support.mozilla.org
Knowledge Base Software
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: nkoth, Assigned: laura)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: sumo_only)

(Reporter)

Description

9 years ago
Set up test procedure and setup on the test cluster in preparation for general performance testing, and search results caching optimization (bug 460214),
(Reporter)

Updated

9 years ago
Blocks: 460230
(Assignee)

Updated

9 years ago
Assignee: nobody → stephen.donner
(Assignee)

Updated

9 years ago
Duplicate of this bug: 460230
Laura, do you have the URL of the test-cluster documentation handy?  I grepped wiki.mozilla.org, but came up rather empty; thanks!
(Assignee)

Updated

9 years ago
Target Milestone: 0.7.3 → 0.8
Sorry, but I looked at this and it's out of my league/skillset (for now, at least, and probably the foreseeable future); it still needs testing though, so could someone else take a look?

Jeremy, is this something you could help out with?
Assignee: stephen.donner → nobody
(Assignee)

Comment 5

9 years ago
If Jeremy has time that would be awesome, otherwise I guess I will have to pick this up.

Comment 6

9 years ago
I think webdev owns the test cluster now, but if you need help with a simple A/B test let me know.
(Reporter)

Updated

9 years ago
Blocks: 405028
(Reporter)

Updated

9 years ago
Summary: Set up testing of new sumo search performance on test cluster → Sumo new search load and performance testing
(Assignee)

Comment 7

9 years ago
I'm actually going to do this *after* freeze since it doesn't require code changes.
(Reporter)

Updated

9 years ago
Blocks: 460213
(Assignee)

Updated

9 years ago
Depends on: 468820
(Assignee)

Updated

9 years ago
Blocks: 469104
(Assignee)

Comment 8

9 years ago
I am in the process of this, don't know why it isn't assigned to me.
Assignee: nobody → laura
(Assignee)

Comment 9

9 years ago
Testing shows we get about 4x req/s on new search vs old.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(In reply to comment #9)
> Testing shows we get about 4x req/s on new search vs old.

Thanks Laura.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Whiteboard: sumo_only
You need to log in before you can comment on or make changes to this bug.