If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Newsreader: the new message header pane doesn't display references

RESOLVED WORKSFORME

Status

Thunderbird
Message Reader UI
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Ilja Sekler, Unassigned)

Tracking

({regression})

Trunk
regression
Bug Flags:
wanted-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081016 Firefox/3.1b2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081016 Thunderbird/3.0b1pre

Before the refactoring of the message header pane, the normal view of message headers contained also a list of clickable references, which allowed a quick navigation backwards in a newsgroup thread. This list was displayed regardless of the value of the preference mailnews.headers.showReferences (that was wrong). Now, with the new message header pane, the references are not displayed at all, even if mailnews.headers.showReferences is set to "true" (this is what this bug is about).

This applies also to View => Headers => All.

Reproducible: Always

Steps to Reproduce:
1. Set the preference mailnews.headers.showReferences to "true".
2. Select a newsgroup message which is a reply to another message in a thread.

Actual Results:  
No references.

Expected Results:  
The references are listed.

A screenshot comparing the old and the new message header pane: https://bugzilla.mozilla.org/attachment.cgi?id=340328
(Reporter)

Updated

9 years ago
Keywords: regression
Version: unspecified → Trunk

Comment 1

9 years ago
Confirmed.
Blocks: 449691
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
If someone wanted to come up with a patch for this, that would be great; marking wanted+ for Tb3.
Component: Mail Window Front End → Message Reader UI
Flags: wanted-thunderbird3+
QA Contact: front-end → message-reader
This was fixed at some stage, I think I even reviewed the patch for it. Marking as WFM
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
right, that was bug 482048 i believe
You need to log in before you can comment on or make changes to this bug.