GMail cut off in Fennec desktop test build

VERIFIED DUPLICATE of bug 458741

Status

Fennec Graveyard
General
VERIFIED DUPLICATE of bug 458741
9 years ago
8 years ago

People

(Reporter: JBundy, Assigned: mfinkle)

Tracking

Trunk
fennec1.0b1
x86
Windows Vista

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Fennec | File version v.1.9.1.3209 | XUL  (Windows Mobile) | Product Version: 1.9.1b2pre | Modified:  10/15/2008 11:38 P.M.

In attempting to access my GMail account through the desktop test build of Fennec for Windows Mobile devices, I am unable to scroll to see the entire web page that displays inbox, chat tab, etc.  Scrolling is inoperable.

Reproducible: Always

Steps to Reproduce:
1. Log in to GMail
2. Click on screen and attempt to drag screen around to view other elements on the page.
3. Zoom out to see if any other data on the page is visible
Actual Results:  
  I logged into my account at GMail.com.  The page loaded my inbox as usual.  When I clicked to drag the screen down so that I could see more messages, the screen would no move.  I zoomed out to see if anything else not already on the screen would show up, but white space filled in the space outside the borders of the original zoom level that I zoomed out from.

Expected Results:  
I should have been able to scroll around freely on the page.  That did not happen at GMail.

Updated

9 years ago
Assignee: nobody → mark.finkle
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Fennec A2
Seems to be related to iframes and our canvas painting. All of GMail is loaded into the browser (DOMi confirms it), but the canvas painting appears to cutoff near the bottom. I can use TAB to move down my inbox and make the botton appear - but then the top is cutoff.

GMail makes heavy use of iframes which could be causing the problem.

Next up is debugging the painting rectangles and looking at content/iframe sizes.

Updated

9 years ago
Depends on: 458741

Updated

9 years ago
Target Milestone: Fennec A2 → Fennec A3
This looks like a test case for bug 458741.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 458741
Google Reader has the same issue.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.