place is lost in message list if opened message is deleted

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: kurt rosenfeld, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b1pre) Gecko/20081006 Shredder/3.0a3

message location returns to top of list.
this does not happen if an unopened message is deleted

Reproducible: Always

Steps to Reproduce:
1.open a message in the list (inbox or any other)
2.click on delete icon (red X) on the menu bar.
3.note position of message selector
Actual Results:  
position of email selection was lost

Expected Results:  
selection should move to next item in list as is the case if an unopened email is deleted

Comment 1

10 years ago
What do you mean by "open". Open in new window, or just in the message pane?
Both ways seem wfm for me though.
(Reporter)

Comment 2

10 years ago
I never use the message pane as any virus in a message would be transferred to the computer by the message pane. I recommend that you advise your users of this and have the message pane turned off as the default setting! 

I open messages by double clicking on them in the list.
If you delete the message (or move it) the place in the list is lost.

If you simply close the window then the place is retained.

Comment 3

10 years ago
OT but a virus being "transferred to the computer" is hardly affected by if you read the message in the message pane or in the standalone window.
(Reporter)

Comment 4

9 years ago
If it is not shown in the message pane the user will have the ability to look at the subject and to delete it without getting the virus.
Assuming of course that he has read elsewhere, the warnings published about the subject.
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3)
> Gecko/2008092417 Firefox/3.0.3
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.9.1b1pre) Gecko/20081006 Shredder/3.0a3

> Steps to Reproduce:
> 1.open a message in the list (inbox or any other)
> 2.click on delete icon (red X) on the menu bar.
> 3.note position of message selector
> Actual Results:  
> position of email selection was lost
> 
> Expected Results:  
> selection should move to next item in list as is the case if an unopened email
> is deleted

WFM 

here with 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1pre) Gecko/20090618 Lightning/1.0pre Shredder/3.0b3pre ID:20090618031425

and diplaying messaage list sort by date gropued by sort.

Deleting first message, select move to the previous (the new first).
WFM per comment 5

Kurt reopen if you still see the issue with current nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
Resolution: --- → WORKSFORME
Version: unspecified → Trunk
(Reporter)

Comment 7

9 years ago
In Thunderbird version 2.0.0.21 (20090302)
The Bug still occurs.
Open a message in a window.
Delete the message.
The next message opens automatically.
Close that message
The cursor has jumped to the 1st message in the list.

If a message is opened manually (rather than automatically because the previous message has been deleted) and then closed the ursor returns to the position of the message which has just been closed.
(Reporter)

Updated

9 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Updated

9 years ago
Whiteboard: closeme 2009-10-23

Comment 9

9 years ago
(In reply to comment #8)
> kurt, please try
> ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/

Tried it with msg pane open in viewer and with opening the msg. In each case when the message was deleted the proper position in the message list was retained. It works for me on the nightly.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091015 Shredder/3.0pre
WFM - Len
WFM per comment 9
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → WORKSFORME
Whiteboard: closeme 2009-10-23
You need to log in before you can comment on or make changes to this bug.