Closed Bug 460487 Opened 16 years ago Closed 16 years ago

Acid 3 reference renders grey (no background image)

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 460796

People

(Reporter: Peter6, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081017 Minefield/3.1b2pre ID:20081017033517

repro:
open FF
open url
press on the link "this reference rendering"
when I press [back] and [forward] the reference is rendered properly

result:
see screenshot

expected:
the correct image

I'm not sure what the cause is, I can't repro with restarting FF

Component GFX:Thebes ?

I'm not sure when this regressed
errr.

I'm not sure what the cause is, I can't repro with restarting FF
should be
I can't repro without restarting FF
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081017 Minefield/3.1b2pre

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081017 Minefield/3.1b2pre

Could not reproduce in 3.1b2pre under Linux or Windows. Reference rendering showed just fine for me.
Blocks: acid3
The same grey image with
Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.9.1b2pre) Gecko/20081017 Minefield/3.1b2pre nightly
when loading acid3 reference for first time. I can't reproduce it after restart.
Caused by a plugin maybe? Try disabling them.
(In reply to comment #4)
> Caused by a plugin maybe? Try disabling them.

Tested with a fresh new profile, of course. And I can reproduce it with another new profile.
So, it doesn't seem to render the background-image(reference.png), just the background-color (#c0c0c0)

in reference.html this is the line

<style type="text/css">
body { background: #c0c0c0 url(reference.png) top left no-repeat; margin: 0; padding: 0; }
</style>
Summary: Acid 3 reference renders grey → Acid 3 reference renders grey (no backgound image)
(In reply to comment #5)
> (In reply to comment #4)
> > Caused by a plugin maybe? Try disabling them.
> 
> Tested with a fresh new profile, of course. And I can reproduce it with another
> new profile.

Plugins are often installed for all users; a new profile does not guarantee you're starting without plugins, just extensions and themes.
Works fine here, with my default profile and with a new profile
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081017 Minefield/3.1b2pre
It seems a sort of lack of refresh.

After opening "View Page Source" window and moving it on top of the grey rendered reference page, the part that were hidden by the window started getting the proper colours.

I closed the source window that acted as a sort of "correct rendering paintbrush" (also the "right mouse button menu" acts as refresh paintbrush),
switched to another tab and then back to the page, and the grey part was completely disappeared.

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081017 Minefield/3.1b2pre
Screenshot of the gray rendering, when opening multiple times the right mouse button menu.
Component: General → GFX: Thebes
Flags: blocking1.9.1?
QA Contact: general → thebes
Did you check your plugins? Only certain people seem to be able to get this and plugins would be the most likely thing to differ between people. (plugins aren't even disabled in safe mode or a new profile)
This bug has nothing to do with plugins
To reproduce it I have to empty the cache before clicking on the reference rendering link.

Latest working (that is, if I clean the cache and click the reference rendering sometimes I can still see the grey version for less than a second, but then the correct one appears):

Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081011 Minefield/3.1b2pre

first with the regression:
Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081012 Minefield/3.1b2pre
that could well point at bug 322475(In reply to comment #13)
> To reproduce it I have to empty the cache before clicking on the reference
> rendering link.
> 
> Latest working (that is, if I clean the cache and click the reference rendering
> sometimes I can still see the grey version for less than a second, but then the
> correct one appears):
> 
> Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.9.1b2pre) Gecko/20081011 Minefield/3.1b2pre
> 
> first with the regression:
> Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.9.1b2pre) Gecko/20081012 Minefield/3.1b2pre

that could well point at bug 322475
Component: GFX: Thebes → General
QA Contact: thebes → general
Component: General → Layout
QA Contact: general → layout
I'm guessing this is the same as bug 460796.
Depends on: 460796
Duping forward because the other bug is simpler and clearer.
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
(fixed typo in summary)
Summary: Acid 3 reference renders grey (no backgound image) → Acid 3 reference renders grey (no background image)
You need to log in before you can comment on or make changes to this bug.