Closed Bug 460560 Opened 13 years ago Closed 13 years ago

Escape key doesn't close the Ctrl+Tab panel on Windows

Categories

(Firefox :: Keyboard Navigation, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 3.1b2

People

(Reporter: dao, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

This is due to noautohide="true", added in bug 451300.
Flags: blocking-firefox3.1?
To fix this, we need to either fix bug 457997 or backout bug 451300.
Depends on: 457997
Isn't there a VK_ESCAPE keypress that the panel could catch (in the same handler is uses for VK_TAB and others)?
(In reply to comment #2)
> Isn't there a VK_ESCAPE keypress that the panel could catch (in the same
> handler is uses for VK_TAB and others)?

We try that, but Ctrl+Esc is handled by Windows.
So if I'm holding down ctrl and hit escape, what did it used to do? Right now it seems to bring up the start menu which is what I expect. Does ctrl-tab no longer dissappear when you release the control key?
(In reply to comment #4)
> So if I'm holding down ctrl and hit escape, what did it used to do? Right now
> it seems to bring up the start menu which is what I expect.

Yes, and at the same time, the panel should disappear. It doesn't do that because of noautohide="true". noautohide="true" also has other implications, neither of which we want.

> Does ctrl-tab no
> longer dissappear when you release the control key?

It does.
Blocks: 461950
Blocks: 463220
hopefully we won't need this
No longer blocks: 463220
Blocks: 463693
Duplicate of this bug: 463755
The patch for bug 457997 seems to fix this (and removes the autohide from ctrl-tab).
No longer blocks: 463693
No longer blocks: 461950
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.1b2
Verified with Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081111 Minefield/3.1b2pre ID:20081111032821
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
Flags: blocking-firefox3.1?
https://litmus.mozilla.org/show_test.cgi?id=7433 added to Litmus.
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.