Rendering of <br> is inconsistent

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: s.mueller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

Hi, my girlfriend (sitting next to me) got a Windows XP SP3 (me too).
When I go on a specified website, displaying a <table> inside a <div>, her firefox is ignoring all <br> in the <td>.

Example code:
<div>
<table>
<tr><td> Hi <br> bye</td></tr>
</table>
</table>

:At her firefox, it is displayed as:
Hi bye

:At my firefox, it is displayed as:
Hi
bye


Why is firefox reacting such different?

IE7 and Opera is displaying everything fine on both pc's.
I told a few friends also to visit the site end tell me their results, 
one of ten got the same weird stuff, that the <br> is ignored.

please fix that.

Reproducible: Always

Steps to Reproduce:
1. use my code listed at "Details".
2. Look with 5-6 different firefox 3.0.3 on the site
3. Feel the difference.





I checked the website with the w3 validator, the site is CSS 2.1 and HTML 4.01 validated.
You already tried the safemode and a new profile before posting the bug report ?
- http://support.mozilla.com/en-US/kb/Safe+Mode
- http://support.mozilla.com/en-US/kb/Managing+profiles

Comment 3

10 years ago
WFM on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081018 Minefield/3.1b2pre.
Summary: differences between Firefox 3.0.3 and Firefox 3.0.3 → Rendering of <br> is inconsistent
(Reporter)

Comment 4

10 years ago
Hi, 
the example I wrote was a cut down of the full source.
Also a copy&paste the sourcecode doesn't reproduce the problem.

But I can hand out 2 screenshots and a copy&paste of the source of the website.
My Firefox:
http://gnas.bnc4you.info/my-firefox.jpg

Her Firefox:
http://gnas.bnc4you.info/girlfriend-firefox.jpg

The Website's source, Copy&pasted to a .html
http://gnas.bnc4you.info/problem.html

And no, she didn't tried the safe mode.
(Reporter)

Comment 5

10 years ago
Oh god damned.

I just looked at the both pictures twice. 
I didn't realize that she doesn't got the [S E M] links, I got.

Seems to be a failure at writing the site, and not a problem with Firefox, which maybe only revealed, since the friends where it happens using wide-screen monitors and resolutions.
(Reporter)

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.