A link inside an iframe from a different domain (w/different stored full page zoom) can cause the whole page to change zoom level.

RESOLVED DUPLICATE of bug 429402

Status

()

RESOLVED DUPLICATE of bug 429402
10 years ago
10 years ago

People

(Reporter: Michael.Balazs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

A link inside an iframe from a different domain (w/different stored full page zoom) can cause the whole page to change zoom level. 


Reproducible: Always

Steps to Reproduce:
Have this (http://userscripts.org/scripts/show/35499) greasemonkey script that loads google calendar into an iframe below the gmail inbox. 

1) Load gmail and make sure the zoom level is reset (i.e. set to zero.) 
2) Load google calendar and set the page to a non-zero zoom level. 
3) Reload gmail (make sure the script enabled.) 
4) In the iframe click one of the calendar tabs to change views.

Actual Results:  
When you do this you should find that the page changes to the zoom level set on the google calendar. Changing the view of the main gmail window resets the page zoom. 

Expected Results:  
The iframe page should not be allowed to change the zoom of the parent page.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 429402
You need to log in before you can comment on or make changes to this bug.