even support for focus event doesn't worked

VERIFIED FIXED

Status

Core Graveyard
Java APIs to WebShell
P3
normal
VERIFIED FIXED
17 years ago
5 years ago

People

(Reporter: Vladimir Strigun, Assigned: Ashu Kulkarni)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: suntrak-n6)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
When we call any of these two methods of WindowControl interface
 void removeFocus()                  
 void setFocus() 
and try to catch the events by regestring event listeners in JavaScript
e.g. window.addEventListener("focus", onFocusGained, false))
in the preliminarily loaded page it doesn't work (no events are caught).
Supposed reason: Even support is unimplemented yet, so code must thrown a 
UNIMPLEMENTED exception

Comment 1

17 years ago
updating product, component and setting default owner.
Assignee: mitchell → jst
Component: Miscellaneous → DOM Level 0
Product: mozilla.org → Browser
QA Contact: desale
Please attach a concrete minimized testcase that points out the problem here,
thanks!
Still no testcase here, reassigning to joki who might know why/what/when about
this...
Assignee: jst → joki
(Reporter)

Comment 4

17 years ago
Change component, QA contact and assign to Ed Burns - default module owner for 
Webclient
Component: DOM Level 0 → Java APIs to WebShell
QA Contact: desale → geetha.vaidyanaathan
(Reporter)

Comment 5

17 years ago
Reassing to Ed Burns
Assignee: joki → edburns

Comment 6

17 years ago
Reassign to Ashu for investigation.
Assignee: edburns → ashuk
(Assignee)

Comment 7

17 years ago
SetFocus funtion in WindowControl calls into the Mozilla
nsIBaseWindow->SetFocus() function. If there is a disconnect here, it is most
probably because something here was broken in the embedding APIs (that gave
access to nsIBaseWindow object) at the time M16 was released.

RemoveFocus - support for this was removed from M15 onwards. Hence there is no
Embedding API by which this functionality can be exposed to the Webclient users.
I will make this throw an UnImplementedException and check in the change. Will
also follow up with Mozilla Embedding folks to find out if this functionality
might come back later.

_Ashu

Status: NEW → ASSIGNED
(Assignee)

Comment 8

17 years ago
Created attachment 14516 [details] [diff] [review]
Proposed patch - diff -u WindowControlImpl.java
(Assignee)

Comment 9

17 years ago
I have a temporary patch for this that throws UnImplementedException for these 2
methods. Will check in once I have r=a=edburns.

_Ashu

Comment 10

17 years ago
r=a=edburns
(Assignee)

Comment 11

17 years ago
Checked patch into cvs that throws UnImplementedException. I wont close this Bug
as yet. After we sync up with the PR3 branch, I'll check if this persists...and
only then will I close/work on this bug.

_Ashu

Comment 12

17 years ago
Adding Status white board keyword to track all existing Webclient bugs
Whiteboard: suntrak-n6
(Assignee)

Comment 13

17 years ago
Created attachment 25230 [details] [diff] [review]
cvs diff -u of WindowControlImpl.java
(Assignee)

Comment 14

17 years ago
I have changed WindowControlImpl.java so that it calls into Native code 
(nsIBaseWindow->SetFocus)when SetFocus is called (instead of throwing 
UnImplementedException). I have also changed the comment in the Exception 
thrown when RemoveFocus is called to indicate that RemoveFocus is no longer 
supported by Mozilla. This function does not make much sense anyways 
considering that SetFocus is provided to Embedders who wish to have the ability 
to TAB through the page being displayed. We should seriously consider removing 
this Function from the API.

QA, pls test whether SetFocus works with your API tests using the 
Netscape6_0_OEM_Branch mozilla codebase. I know this didn't work with M16. 

Ed, do I have ra=edburns for checking this in?

thnx
_Ashu

Comment 15

17 years ago
Looks good.  r=edburns
(Assignee)

Comment 16

16 years ago
SetFocus seems to work and RemoveFocus is no longer supported in Gecko 
Embedding. Would the reporter pls verify that the SetFocus works. I am closing 
this Bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 17

16 years ago
Mark this bug as verified.
Verified with Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.1) Gecko/20010910
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

16 years ago
Change cc
Component: Java APIs to WebShell → Java APIs to WebShell
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.