user password can get from password manager

RESOLVED INVALID

Status

SeaMonkey
Passwords & Permissions
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: shiforsisters, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.0.04506; MEGAUPLOAD 3.0; CIBA)
Build Identifier: 

when get into the password manager clicking shown password. user password can be shown to others.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Please specify:
- exact steps to reproduce (1. 2. 3. etc.)
- actual results
- expected results
- Build ID as shown at the bottom of the page which appears when you type "about:" without the quotes in the URL bar of the browser where you had the problem. The preeferred method for copying it is by copy/paste over the clipboard.

If it's in IE7 (used to report this bug) that you saw the problem, you should report it (if possible) to Microsoft, not here.
"Show Passwords" is a SeaMonkey feature, not a bug.

R.Invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Component: General → Passwords & Permissions
QA Contact: general → privacy
Resolution: --- → INVALID
Version: unspecified → Trunk
(In reply to comment #2)
> "Show Passwords" is a SeaMonkey feature, not a bug.
> 
> R.Invalid

Ah, that's what he meant. Yes, it's a feature, and Firefox and Thunderbird have it too (and have had it as long as I can remember). Of course it means you shouldn't "confirm" the show-passwords feature unless you know that no one other than you will have the opportunity to read those passwords before you close the passwords window. In addition, it also means (I suppose) that you should either close the X11/Windows/Mac session (which is protected by your log-in password) when leaving the computer, or at least protect your Sm/Fx/Tb passwords by a "master password" if there's the least risk of someone having access to your logged-in session while you're away.
OS: Windows Vista → All
Hardware: PC → All
You need to log in before you can comment on or make changes to this bug.