convert to event / task is adding to's and cc's to attendees - should warn user if not a member

VERIFIED DUPLICATE of bug 462109

Status

Calendar
General
--
enhancement
VERIFIED DUPLICATE of bug 462109
9 years ago
9 years ago

People

(Reporter: jens.poenninghaus, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.8.1.17) Gecko/20080829 Firefox/2.0.0.17 Mnenhy/0.7.5.666
Build Identifier: lightning 0.9 build 2008091719

Converting a received mail from a mailing list might end in an event having the list as an attendee. Each modification of the event will go to the list.
Technically this is surely no error but from a users perspective it'll be good to at least issue a warning if his own email address is not in the to or cc headers.
 

Reproducible: Always

Steps to Reproduce:
1. user B: send a mail from email address B to address B as a 'to' and to user A as a 'bcc'
2. user A: convert that mail to an event (observe user B as an invitee; which even experienced user will happily miss to spot)
3. User B: see inbox/calendar for event details


Actual Results:  
mailing list (user B) got invitation to event

Expected Results:  
Reduce comfort in favor of avoiding unwanted bulk invitations.
As said, at technical level everything is fine; to and cc are invited and the user has the opportunity to prevent this from happening; but that's not what is going to happen.
One option might be to check, whether mail address of current mail user matches to or cc and issue a warning if it doesn't to reduce risk of firing to a list. Another option (preferred) might be to have a selection box to (de-)select from, to's and cc's for the event _before_ it is possible to add the event to the calendar.


Learned the hard way while using wcap calendars. 
Converting to a task does not even allow to remove 'B' from the list of invitees :-(

Comment 1

9 years ago
Resolve as duplicate of newer (but confirmed) Bug 462109?

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 462109
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.