If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Restoring default start page blanks textbox on Windows

RESOLVED FIXED in Thunderbird 3.0b1

Status

Thunderbird
Preferences
P3
normal
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Matej Krajčovič, Assigned: philor)

Tracking

({regression})

Trunk
Thunderbird 3.0b1
x86
Windows XP
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/525.13 (KHTML, like Gecko) Chrome/0.2.149.30 Safari/525.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081020 Shredder/3.0b1pre ID:20081020030833

When I clicked on "Restore Default" button in Tools -> Options -> General, it filled  "Location" textedit with the default adress for a moment, but then it cleared it.

Reproducible: Always

Steps to Reproduce:
1.Change start page to "http://www.google.com".
2.Restart Shredder.
3.Click on "Restore Default".


Expected Results:  
Fill textedit with default page.

I used default theme.

Comment 1

9 years ago
"Restore Default" seems to actually really restore the url
It's functional, but just not visible until you open the options page again.
Tested with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081020 Lightning/0.6a1 Shredder/3.0b1pre ID:20081020030833
Strange, this works fine for me on: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081020 Lightning/1.0pre Shredder/3.0b1pre

Maybe we're looking at a windows-only problem.

Comment 3

9 years ago
WFM on linux too.
Keywords: regression
Whiteboard: [windows only?]
(Assignee)

Updated

9 years ago
Duplicate of this bug: 461593
I am having this issue (I wrote Bug 4615930) and can confirm on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b2pre) Gecko/20081024 Minefield/3.1b2pre.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 6

9 years ago
Created attachment 344719 [details] [diff] [review]
Fix v.1

Not really clear just what 1.8 bug was being worked around in bug 372671, but it's pretty clear we don't want the workaround on the trunk anymore. Stepping through in Venkman, you see resetting the pref fire a syncfrompref that sets the textbox value (where you see the value for a moment), then the reset starts firing all sorts of things (and sails past a if (instantApply) return, so it's probably only Windows-only because that's the only place we don't have instantApply on), eventually syncing the textbox to nada.
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #344719 - Flags: review?(bugzilla)
(Assignee)

Updated

9 years ago
Whiteboard: [windows only?]
Version: unspecified → Trunk
(Assignee)

Updated

9 years ago
Priority: -- → P3
Summary: cannot restore default start page → Restoring default start page blanks textbox on Windows
Attachment #344719 - Flags: review?(bugzilla) → review+

Updated

9 years ago
Keywords: regression → checkin-needed
Phil is quite capable of checking in his own bugs. Please leave checkin-needed to the patch submitter to add if necessary.
Keywords: checkin-needed → regression
(Assignee)

Comment 8

9 years ago
http://hg.mozilla.org/comm-central/rev/a875ba644fa9

Whew. Thought for a minute there my commit access had been revoked, and nobody wanted to tell me directly.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b1
Duplicate of this bug: 462401
You need to log in before you can comment on or make changes to this bug.