Closed Bug 460796 Opened 12 years ago Closed 12 years ago

canvas background (from <body>) not invalidated correctly when image animates or loads

Categories

(Core :: ImageLib, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.1b2

People

(Reporter: stebs, Assigned: dbaron)

References

()

Details

(Keywords: fixed1.9.1, regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081020 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081020 Minefield/3.1b2pre

The url above should open an Page where everything is moving.
Instead, only half of the first "row" is animated.

Regression Range is between these Nightlies:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081011 Minefield/3.1b2pre works
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081012 Minefield/3.1b2pre does not work

Fx 3.0.3 is ok. 

Reproducible: Always
Confirmed on Windows XP, latest trunk.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bug 322475 seems the most likely cause.
Blocks: 322475
I also see this on Linux in a current nightly.
OS: Windows XP → All
Hardware: PC → All
OS: All → Windows XP
Hardware: All → PC
OS: Windows XP → All
Hardware: PC → All
Maybe we're now missing special code to invalidate the canvas when body's background changes...
Oh, I bet the old code associated the body's background with the canvas frame, and the new code associates it with the body's frame.  We might need to use FindBackground somehow, and somehow fix handling of when the "body element" or root element changes, or something else...
Summary: APNG rendering only part of animation (Regression) → canvas background (from <body>) not invalidated correctly when image animates or loads
Duplicate of this bug: 460487
I think it's probably easiest to revert bug 322475 and go back to the two-table structure, and then change that structure to deal with multiple backgrounds.  I think there might also be issues with things like table rows/cols and spanning cells.
Assignee: nobody → dbaron
Status: NEW → ASSIGNED
Flags: blocking1.9.1?
Fixed by backouts:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6fc233a8263d&tochange=16710698149f
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.1b2
Flags: blocking1.9.1? → blocking1.9.1+
Keywords: fixed1.9.1
You need to log in before you can comment on or make changes to this bug.