Closed Bug 460906 Opened 12 years ago Closed 11 years ago

Change "Find in this page" box to a "find as you type" bar which is more convenient and effective when searching.

Categories

(SeaMonkey :: Find In Page, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 97023

People

(Reporter: s5752906, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081020 SeaMonkey/2.0a2pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b2pre) Gecko/20081020 SeaMonkey/2.0a2pre

The default “Find in this page” box is quite large and covers part of the page you are viewing. You have to move it around to view the whole page. And sometime when you are searching for a word or phrase, you find that result had actually appeared behind the find menu. 

With the find as you type bar:-
- A search pane is placed at the bottom of the browser window. 

- It will have "Find as you type" functionality.

- Highlight all feature can locate every instance of your search string and highlight them. 

- Buttons on the search pane let you jump to the previous or next instance of your search string on the current web page.

- When you type a word you're looking for, the color of the toolbar’s search field remains white as long as the string of characters you are typing can be found on the page. As soon as the set of characters you are typing is not present on the page, you get informed by a color change within the search field.


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Summary: Change "Find in this page" box to a find as you type bar which is more convenient and effective when searching. → Change "Find in this page" box to a "find as you type" bar which is more convenient and effective when searching.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 97023
You need to log in before you can comment on or make changes to this bug.