registerProtocolHandler for mailto - issues with window.history

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: Plucera, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; sv-SE; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

I have registered a uri for mailto-links with registerProtocolHandler. When clicking a mailto-link, the uri it goes to doesn't get correctly registered in window.history.

Since our compose page is displayed in a pop-up I want the users to go back to the page were the link was clicked. When issuing a window.history.back() it doesn't always return to the previous page. 

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.plucera.se/setMailHandler.htm and klick on "Set handler"
2.Open new window and go to random url
3.In that window go to http://www.plucera.se/setMailHandler.htm and klick on "user@host.com", select MailtoHandler as your "software" to launch.
4.Click the "Back"-button
5.Do step 3 and 4 again.
Actual Results:  
You are taken to the "random url" page instead om the setMailHandler.htm page.

Expected Results:  
You should always see the calling page when history.back() is called.

This is also happening in: Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.9.1b1pre) Gecko/20080916043910 Minefield/3.1b1pre
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.