File upload field (<input type="file">) locks file

RESOLVED DUPLICATE of bug 183689

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 183689
9 years ago
9 years ago

People

(Reporter: paul stanton, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

if i upload a file using the file input, i can't delete it from the filesystem until i close firefox.

happens every time on an internal system which i can't show you, but doesn't happen on some other sites such as imageshack.

the file handle should be released once the request has been sent.

the file in question is a 773kb xml doc.

sorry if this is a red herring.

Reproducible: Sometimes

Steps to Reproduce:
1. browse for xml doc
2. submit form
3. try to delete file on local file system
-doesn't work
4. close browser
5. delete file from local file system
-works
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 183689
Duplicate of this bug: 464929
You need to log in before you can comment on or make changes to this bug.