Deliver NSS 3.12.2 Mozilla

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
8 months ago

People

(Reporter: kaie, Assigned: kaie)

Tracking

({verified1.9.0.5})

Trunk
verified1.9.0.5
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

10 years ago
Deliver NSS 3.12.2 and NSPR 4.7.2 to Mozilla

We'd like to start doing this for Mozilla trunk now, and deliver to Firefox 3.0.x branch, once 3.0.4 is done.
(Assignee)

Comment 1

10 years ago
Created attachment 344226 [details]
Proposal for updating NSS

Nelson or Wan-Teh, could you please approve this plan (as discussed earlier)?
Attachment #344226 - Flags: superreview?(wtc)
Attachment #344226 - Flags: review?(nelson)
(Assignee)

Updated

10 years ago
Attachment #344226 - Flags: review?(nelson) → review?(rrelyea)
(Assignee)

Updated

10 years ago
Attachment #344226 - Attachment is obsolete: true
Attachment #344226 - Flags: superreview?(wtc)
Attachment #344226 - Flags: review?(rrelyea)
(Assignee)

Comment 2

10 years ago
Created attachment 344395 [details]
proposal
Assignee: nobody → kaie
Attachment #344395 - Flags: review?(wtc)
(Assignee)

Updated

10 years ago
Blocks: 461250

Comment 3

10 years ago
Comment on attachment 344395 [details]
proposal

r=wtc.
Attachment #344395 - Flags: review?(wtc) → review+
(Assignee)

Comment 4

10 years ago
marking fixed.

Should the current NSS 3.12.2 release candidate not be the final one, I might reopen this bug.

78d4f20a71a8
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

10 years ago
Created attachment 346074 [details] [diff] [review]
equivalent for mozilla 1.9.0
Attachment #346074 - Flags: approval1.9.0.5?
(Assignee)

Comment 6

10 years ago
cc'ing NSPR and NSS folks, just FYI, to let you know we're now going to deliver NSPR 4.7.2 and NSS 3.12.2 (RC1) to the stable Firefox 3.0.x branch

Comment 7

10 years ago
NSPR 4.7.2 has a regression that affects Solaris 8 and 9 only
(bug 461502).  It would be nice to wait for NSPR 4.7.3.  You
can deliver NSS 3.12.2 (RC1) first.
How much of a wait? This sort of change we'd like to get in at the beginning of a release cycle for testing since there's not great coverage of NSS and NSPR features.
(Assignee)

Comment 9

10 years ago
(In reply to comment #8)
> How much of a wait?

Looks like a fix for bug 461502 is not yet in hand.

Let's go with Wan-Teh's proposal and land the newer NSS, only.
I'll attach a new patch.
(Assignee)

Comment 10

10 years ago
Created attachment 346137 [details] [diff] [review]
Patch for 1.9.0, only NSS; v2
Attachment #346074 - Attachment is obsolete: true
Attachment #346137 - Flags: approval1.9.0.5?
Attachment #346074 - Flags: approval1.9.0.5?
Comment on attachment 346137 [details] [diff] [review]
Patch for 1.9.0, only NSS; v2

Approved for 1.9.0.5. a=ss

Please land when the tree is open. Also, track the addition of a  new NSPR on the 1.9 branch in a new bug.
Attachment #346137 - Flags: approval1.9.0.5? → approval1.9.0.5+
(Assignee)

Comment 12

10 years ago
changing subject to be about NSS, only.

Checked in to cvs for 1.9.0.5

Will probably use bug 463073 for NSPR 4.7.3 upgrade (once solaris bug has been baken and rtm tag declared)
Keywords: fixed1.9.0.5
Summary: Deliver NSS 3.12.2 and NSPR 4.7.2 to Mozilla → Deliver NSS 3.12.2 Mozilla
Verified that this is checked in. Not much to do here for 1.9.0.5.
Keywords: fixed1.9.0.5 → verified1.9.0.5

Updated

10 years ago
Blocks: 471424

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.