Note: There are a few cases of duplicates in user autocompletion which are being worked on.

RFE: export function CERT_CompareCerts

RESOLVED FIXED in 3.12.3

Status

NSS
Libraries
P2
enhancement
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: rocketraman, Assigned: Nelson Bolyard (seldom reads bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.0.3) Gecko/2008092416 Firefox/3.0.3
Build Identifier: 

As per bug #354273, function CERT_CompareCerts needs to be exported.

Reproducible: Always
(Reporter)

Updated

9 years ago
Blocks: 354273
Assignee: nobody → nobody
Component: General → Libraries
Product: Thunderbird → NSS
QA Contact: general → libraries
thanks, Phil.
Assignee: nobody → nelson
OS: Linux → All
Priority: -- → P2
Hardware: PC → All
Target Milestone: --- → 3.12.3
Version: unspecified → trunk
Created attachment 344448 [details] [diff] [review]
patch v1 - export symbol

This should do it.
Attachment #344448 - Flags: review?(kaie)
(Assignee)

Updated

9 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 3

9 years ago
Comment on attachment 344448 [details] [diff] [review]
patch v1 - export symbol

That's one rather trivial function.

Also its implementation can be optimized by checking that pointers are equal, since typically most certs that have the same DER will end up pointing back to the same structure.
Attachment #344448 - Flags: review?(kaie) → review+
Yes, I think that optimization actually belongs in SECITEM_CompareItem.
I'm surprised it isn't already there.
Created attachment 344943 [details] [diff] [review]
patch part 2, v1 - optimization
Attachment #344943 - Flags: review?(julien.pierre.boogz)

Updated

9 years ago
Attachment #344943 - Flags: review?(julien.pierre.boogz) → review+
Checking in nss/nss.def;    new revision: 1.195; previous revision: 1.194
Checking in util/secitem.c; new revision: 1.15; previous revision: 1.14
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.