Closed Bug 461125 Opened 14 years ago Closed 14 years ago

Select fields not rendered properly

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(fennec1.0b2+)

VERIFIED DUPLICATE of bug 472426
fennec1.0b1
Tracking Status
fennec 1.0b2+ ---

People

(Reporter: krudtaa, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: 1.0a1.en-US.win32

I'm using the windows version, so I do not know how releveant this bugrep is... but anyway...

Select fields are rendered weirdly:
1. The down arrow at right-hand side of the select is not visible.
2. When I click the select to open the list, then the elements (list) are displayed in wrong position on the page.

That said... this mobile browser is going to kick some butt. Really nice Alpha version this is. Also look like it has very good javascript support.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Assignee: nobody → gavin.sharp
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-fennec1.0+
Target Milestone: --- → Fennec A3
> 2. When I click the select to open the list, then the elements (list) are
> displayed in wrong position on the page.

it seems that disabling content autocomplete (in bug 466728) just masks the mis-align real problem between the canvas and content popup windows (content autocomplete, select lists dropdown, etc)...
That popup windows rendered in separate native popup window...
I think we should render select/option list with RenderDocument and not create popup window...
tracking-fennec: --- → 1.0+
I ran into this problem and we should consider fixing this sooner rather than later.  

I go to a website and the <select> field looks like a <input type="text">.  This is confusing.  What makes it worse is the soft keyboard does not pop up.  If I slide the screen up and get the hard keyboard, I can type and get the selection I want.
Assignee: gavin.sharp → nobody
OS: Windows XP → All
Hardware: x86 → All
tracking-fennec: 1.0+ → 1.0b2+
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 472426
verified with nightly build of maemo 20090818
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.