Editing drafts within Subfolders of the "Draft" folder

RESOLVED DUPLICATE of bug 263114

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 263114
9 years ago
8 years ago

People

(Reporter: Patrick Rynhart, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.16) Gecko/20080702 Firefox/2.0.0.16
Build Identifier: version 2.0.0.16 (20080708)

Thunderbird doesn't correctly handle drafts located in subfolders of the main "Draft" folder.  Steps to reproduce:

1) Create a subfolder "foo" of the Drafts folder.
2) Compose a message (subject "bar"), select File -> Save and then close the Message Window.
3) Move the message from Part 2, which currently should be in the "Drafts" folder, to the subfolder "foo".
4) Enter the subfolder "foo", highlight the message with subject "bar" and then click the button "Edit Draft..."
5) Update the message and then save again.  Thunderbird will incorrectly save the message within the Draft parent folder.  This results in duplicated messages - along with the original draft which isn't updated.

Reproducible: Always

Steps to Reproduce:
Please see the details section above.
Actual Results:  
Please see the details section above.

Expected Results:  
Please see the details section above.
> Thunderbird will incorrectly save the message within the Draft parent folder. 

Save target folder of "Save As Draft" is always folder specified in your prefs.js, since initial of Mozilla family(same design as Netscape 4 or before).
  When Tb 2, defined at next.
    Tools/Account Settings/Manage Idenitities, Copies&Folders/Draft and Template
    (mail.identity.idX.draft_folder in prefs.js)
If you want the draft mail to be saved in subfolder of Drafts folder, it's new enhancement request. However, if you feel enabling of "Edit Draft" button for mail in subfolder under Drafts is confusing(or wrong), it's DUP of Bug 263114.
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263114
You need to log in before you can comment on or make changes to this bug.