"ASSERTION: mCurrentNode is NULL" with XSLT, iframe

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
5 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

(Blocks: 1 bug, {assertion, memory-leak, testcase})

Trunk
x86
Mac OS X
assertion, memory-leak, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

451 bytes, text/html
Details
97 bytes, application/xhtml+xml
Details
(Reporter)

Description

10 years ago
###!!! ASSERTION: mCurrentNode is NULL: 'mCurrentNode', file /Users/jruderman/central/content/xslt/src/xslt/txMozillaXMLOutput.cpp, line 573

+ leak an nsStringBuffer and an nsVoidArray

The testcase's two files, m7.html and inner.xhtml, must be saved in the same directory.  It takes about 5 seconds to run and usually triggers the bug once or twice.  It is somewhat similar to the testcase in bug 458637.
(Reporter)

Comment 1

10 years ago
Created attachment 344439 [details]
m7.html
(Reporter)

Comment 2

10 years ago
Created attachment 344440 [details]
inner.xhtml
(Reporter)

Comment 3

9 years ago
Still happens on mozilla-central.
This is almost certainly a dupe of or related to Bug 603844.  I see this assert with that testcase, and as I pointed out in comment 5, that pattern that leaks happens several times in that file.
(Reporter)

Comment 5

5 years ago
WFM, maybe it was fixed by bug 603844.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.