make clean fails in debug builds

RESOLVED FIXED

Status

Firefox Build System
General
--
major
RESOLVED FIXED
10 years ago
2 months ago

People

(Reporter: bc, Assigned: jimb)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Doing a make -f client.mk clobber in linux now fails for debug builds.

I've been able to reproduce this on up to date centos5 vms but not with somewhat out of date centos5 physical machines.

gmake[2]: Entering directory `/work/mozilla/builds/1.9.1/mozilla/firefox-debug/browser/installer'
Makefile:70: *** you need a "--enable-static or --enable-libxul" build to package a build.  Stop.

I changed the mozconfig to include --disable-installer but it had no effect.

I'm pretty sure bug 422991 is the cause.

mozconfig:

. $topsrcdir/browser/config/mozconfig

CPU=`cat /proc/cpuinfo | grep 'processor.*: [0-9]*' | wc -l`
let J=$CPU+1
if [[ $J -gt 4 ]]; then let J=4; fi


mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/firefox-debug
mk_add_options MOZ_MAKE_FLAGS=-j${J}
mk_add_options MOZ_CO_PROJECT=browser

ac_add_options --enable-application="browser"
ac_add_options --disable-optimize
ac_add_options --enable-debugger-info-modules=all

ac_add_options --enable-debug
ac_add_options --disable-tests
#ac_add_options --enable-canvas
#ac_add_options --enable-svg
#ac_add_options --enable-pango
ac_add_options --enable-default-toolkit=cairo-gtk2
ac_add_options --disable-static
ac_add_options --enable-shared
#ac_add_options --enable-places

ac_add_options --disable-crashreporter
ac_add_options --disable-installer
ac_add_options --disable-jemalloc
ac_add_options --with-valgrind
Flags: in-testsuite-
Flags: in-litmus-
I'd say everything between lines 54 and 67 in 
http://mxr.mozilla.org/mozilla-central/source/browser/build.mk#54

should be depending on MOZ_INSTALLER, for a starter...

Mand maybe http://mxr.mozilla.org/mozilla-central/source/browser/installer/Makefile.in#70 should not really error out. A warning may suffice.
(Reporter)

Comment 2

10 years ago
I see this also on Mac OS X intel 10.5.5 but not it seems on Mac OS X intel kernel 10.4.11

Updated

10 years ago
Duplicate of this bug: 463136
(Assignee)

Updated

10 years ago
Assignee: nobody → jim
(Assignee)

Comment 4

10 years ago
I can reproduce this on Linux, with M-C trunk.
Status: NEW → ASSIGNED
(Assignee)

Comment 5

10 years ago
Created attachment 348649 [details] [diff] [review]
Bug 461309: Let browser/installer/Makefile.in permit 'make clean' in debug builds.

[Not sure I've got all the angles here, but this does seem to work.]

The 'clean' and 'distclean' targets may need to recur into
browser/installer/Makefile.in.  Don't run afoul of the code to protect
us from packaging debugging builds.
Attachment #348649 - Flags: review?(benjamin)

Comment 6

10 years ago
Comment on attachment 348649 [details] [diff] [review]
Bug 461309: Let browser/installer/Makefile.in permit 'make clean' in debug builds.

Boy that's ugly, but I hate to bikeshed over a cleaner error message.
Attachment #348649 - Flags: review?(benjamin) → review+
(Assignee)

Comment 7

10 years ago
Well, a bikeshed discussion would require me to have preferences that conflict with yours, which isn't the case.  :)  Just say how you think it should be, and I'll make it so.
(Assignee)

Updated

10 years ago
Whiteboard: checkin-needed
(Assignee)

Comment 8

10 years ago
Landed: 86e908446af4
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Being a bikeshedder of the first order, I'm going to stomp on your message in bug 469789 (which seems only fair, since you bitrotted me by traveling back in time and patching this before I had a chance to push mine) - I'm aiming at getting rid of any mention of "--enable-static" since for Firefox that dies in configure, and mentioning every single thing they might have done, including --enable-shared, to wind up with a non-libxul build, in the vain hope of not seeing any more bugs where someone shrieks about how Firefox can't be built on Linux, you idiots!!
(Assignee)

Comment 10

10 years ago
That's a-okay with me. :)
Whiteboard: checkin-needed

Updated

2 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.