Would like to see a "close tab" icon on the address bar

VERIFIED WONTFIX

Status

--
enhancement
VERIFIED WONTFIX
10 years ago
9 years ago

People

(Reporter: krudtaa, Assigned: madhava)

Tracking

({uiwanted})

Trunk
x86
Windows XP
uiwanted

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: 1.0a1.en-US.win32

I would like to see a close icon on the address bar if there is more than one
folder open. 
Reason... so I do not have to scroll to left to be able to see the current folders in order to close it.
When closing the current one, when clicking the icon, then the previously active folder should be activated.

It could be some icon that makes itself visible when doing "something" on the addressbar or something so it does not take up space when not needed.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.
What do you mean by "folder", exactly? A folder is generally a place on your hard drive to store files. Are you downloading a file?
(Reporter)

Comment 2

10 years ago
Sorry... replace Folder with Tab
Summary: Would like to see a "close folder" icon on the address bar → Would like to see a "close tab" icon on the address bar
(Assignee)

Comment 3

10 years ago
hey -

Please correct me if I'm misinterpreting, but it sounds like the real problem here is that you're finding it difficult to close multiple tabs in a row, and putting a close button in the address bar is one possible solution.

Simplicity of the primary UI is a central theme of of the UI design, so I think that there's a pretty high bar for getting more buttons into the address bar.  It doesn't feel to me like this one qualifies.

Is the the multiple tab closing use case the one you're running into?  If not, can you explain a little more about why you're finding it frustrating to move over to the sidebar?
(Reporter)

Comment 4

10 years ago
Just that it is simpler to click once to close, than having to:

a) first move over to sidebar
b) close the tab

I do not find the current implementation "difficult"... just takes more time.

I'm just trying to say that I would like to see a one click solution.
Where I click does not really matter to me, what matters is that I do not want to do other stuff before being able to click (close the tab).

The reason I wrote this was after I tested som online web application I have developed for a customer.
Some of the stuff there requires the user to open a popup window in order to display a changelog. After the user has read what he wanted, he is supposed to close the popup (here the tab, I guess) in order to get back to previous tab.
When I was done with the changelog tab, I wanted to be able to click once somewhere in the tab in order to close it..... felt that it should be simpler than having to move over to sidebar first.....

Just my 50 cents :)

Updated

10 years ago
Assignee: nobody → madhava
Keywords: uiwanted
Perhaps a key-shortcut for tab close and navigation would be more helpful here. Adding buttons to the toolbar won't happen easily - we want as few toolbar buttons as we can. An extension could add the button.

Comment 6

10 years ago
The toolbar button won't work if the popup is larger than a screen anyway, as you'd possibly need to scroll back up to the top to find the close button.

A better solution is probably the gesture support we're working on in bug 476425.
We are not adding a "close tab" button to the toolbar
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
verfied as wontfix...we have a good solution.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.