Crash in [@ HPSmartPrint@0xe1ef ] after opening print dialog and canceling

RESOLVED WORKSFORME

Status

()

P2
critical
RESOLVED WORKSFORME
10 years ago
4 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Mac OS X
crash, regression
Points:
---
Bug Flags:
blocking1.9.1 -
wanted1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

Seen while running Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081023 Minefield/3.1b2pre.

STR:
1. Open the print dialog.
2. Cancel out of it.
3. Go about and do some other things, and then Crash comes

Those are the best STR I could come up with. I was able to crash in almost every session, but in one instance I may have crashed while the print dialog was still up.

Tomcat found this bug on Windows - he was printing when he crashed but he was not able to readily reproduce the bug, whereas I was using Mac.

Breakpad: http://crash-stats.mozilla.com/report/index/420d904a-a114-11dd-9fe0-001cc4e2bf68
Note, i was seeing this also on Windows Trunk while trying out my ticket from expedia. 

The Printing Problem is also mentioned here http://forums.mozillazine.org/viewtopic.php?p=4802505#p4802505
Flags: blocking1.9.1?

Updated

10 years ago
Severity: normal → critical
Keywords: regression
@Carsten: if it crashed for you in nsPrintSettingsWin.cpp i bet it's Bug 461283. this here seems different (maybe caused by the same checkin though).
Keywords: regressionwindow-wanted
(Reporter)

Comment 3

10 years ago
timeless asked me to test this bug without extensions. I tested this with both an existing profile and a new profile and I still crash 100% of the time using  Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081025 Minefield/3.1b2pre.
(Reporter)

Comment 4

10 years ago
Is it possible this crash may have been caused by Bug 459674? I can check the build the day before this was checked in to see if I can reproduce the crash.
(Reporter)

Comment 5

10 years ago
I tested Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081021 Minefield/3.1b2pre and the crash still occurs in that build, so you can ignore Comment 4.
Summary: Crash in [HPSmartPrint@0xe1ef] after opening print dialog → Crash in [HPSmartPrint@0xe1ef] after opening print dialog and canceling
(Reporter)

Comment 6

10 years ago
Created attachment 344800 [details]
Apple Crash report

Adding the apple crasher report. 

I worked with timeless to start my Mac in safe mode with everything disabled (including wireless), and I was able to reproduce the crash in that mode as well with the HP printer set as default. It did not crash when I switched the default printer to something other than HP (Epson) in System Preferences before opening the print dialog.
(Reporter)

Comment 7

10 years ago
Adding kev to the cc list to see if he has a contact at HP.
Attachment #344800 - Attachment mime type: application/rtf → text/plain
The crash doesn't happen in thread 0 where the hp frames are listed. Instead thread 1 crashed:

Thread 1 Crashed:\
0   ???                           	0x00003018 catch_exception_raise + 0\
1   libSystem.B.dylib             	0x949ab683 exc_server + 117\
2   XUL                           	0x00e4407f XRE_GetFileFromPath + 18799\
3   libSystem.B.dylib             	0x949266f5 _pthread_start + 321\
4   libSystem.B.dylib             	0x949265b2 thread_start + 34\

But anyhow it seems to be related to the printer settings.

Comment 9

10 years ago
i'm assuming that because the stack in the apple crash for thread 0 matches ours from crash reporter which it claims is the crashing thread that it's right...
(Reporter)

Comment 10

10 years ago
This crashes using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.3) Gecko/2008092414 Firefox/3.0.3 as well, in the same stack, http://crash-stats.mozilla.com/report/index/9772b7cf-a374-11dd-9df1-001a4bd43ed6.

Comment 11

10 years ago
Would love to see a fix for this but I don't think the crash is critical enough to block. We can always put a fix in an update.
Flags: wanted1.9.1+
Flags: blocking1.9.1?
Flags: blocking1.9.1-
Priority: -- → P2
(Reporter)

Comment 12

10 years ago
I am seeing this bug consistently today whenever I print on the Mac using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090331 Shiretoko/3.5b4pre. I did see it manifest itself yesterday. Basically I print to a network printer in the office (HP 4350 printer) 

Breakpad from today: http://crash-stats.mozilla.com/report/index/d1f72895-818b-4818-a670-147f22090331
(Reporter)

Comment 13

10 years ago
So moments ago I was seeing this crash consistently on both trunk and 1.9.1. I then went to http://downloads.canon.com/cpr/software/imagerunner/UFRII_v1.80_MacOSX.zip and downloaded the file there and restarted my machine. I did not see that printer come up in my list, but after installing that software I tried printing to Quicksilver and Tiger printers and did not get a crash.

So I am not sure what happened here. The printer crashes seemed to happen well after the print command was initiated from the File menu. And it seemed to crash even when I had the Print options dialog open when I was trying to add new printers. I did not crash when printing to my local Epson printer.
I just tried printing a few docs to the "quicksilver" office printer (the same one Marcia was using in comment 12) using a mozilla-central nightly on my OS X machine, and I couldn't reproduce any crashes. I tried canceling the print dialog a few times, too, as suggested in comment 0, and then navigating around a bit afterwards, but no crashes yet...

I haven't installed the Canon driver mentioned in comment 13, so I don't think that's a factor.  I'm using a fairly pristine OS X machine (since I don't use it that much).

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090331 Minefield/3.6a1pre

Comment 15

10 years ago
This is crashing for me when I do a regular print, print to PDF, or even just sit with the print dialog up for about a minute.  The regular print of mozillazine.org crashes every time.  I tried these versions several times:

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4pre) Gecko/20090416 Shiretoko/3.5b4pre
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

Crash ids:
c6512fd4-f167-42ab-abee-531f72090424
81c8df10-b94b-4162-95cb-a856b2090424
db453813-986f-4779-947b-191b92090424

My printer is a Canon iP4300

Comment 16

10 years ago
I can also get this to crash by picking almost any page (litmus.mozilla.com test case), bugzilla page (this one!) and selecting an HP or Lexmark printer that is configured but not connected.  Cancel the print and wait about 45 seconds.  Crashes every time.  This should be very reproducible in the office later today.  With or without a printer!

Printer selected: HP LasterJet 1320
Crash id: dc73552c-7740-4451-bca8-16d602090424

Printer selected: Lexmark E234n
Crash id:  1b3adb61-4626-42fd-8c29-06d512090424

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

Comment 17

10 years ago
tim: this bug is about an hp printer driver. however all 5 of your stacks point to that driver :)

Comment 18

10 years ago
(In reply to comment #17)
> tim: this bug is about an hp printer driver. however all 5 of your stacks point
> to that driver :)

timeless: I don't get the "however" part or the point of this comment.  Could you clarify?

I have now used Canon, HP and Lexmark printers (or at least the drivers that came with them) and they all crash.  Do they all call use the HPSmartPrint driver?  Sounds unlikely.  Or is this a default driver on Mac OS?

I am able to get a reproducible crash on our MoCo Rainbow printer.
c6436f4e-98e1-4e28-b8ff-95f872090424

Comment 19

10 years ago
Finally found a way to install a different printer.  This is for our Canon iR C4080/C4580 upstairs in building K.  Printing a local jpg file as the content on a printing using this canon driver worked fine.  

Summary for me: 
* Crashes when...
** if I try to print a variety of web pages (mozilla zine,org, buzilla.mozilla.org, litmus.mozilla.org) and local files (.jpg) loaded in the content window. And...
** I do a regular print, print to pdf, or cancel the print.  It crashes about 40-60 sec after pressing print. And ...
** I use a canon printer (iP4300 with an installed driver I am pretty sure), or other printers (HP Laserjet 1320, Lexmark E234n, HP Laserjet 4350n, HP COlor Laserjet 3800dn)  that picked up a default driver.  The traceback shows it in HPSmartPrint

* Does not crash which I print to a Canon iR C4080 printer/copier that I cleanly installed the Canon iR C4080/C4580 driver on.

I don't think this is a show stopper since there are not a lot of other reports.  But HP printers are pretty common so we should understand this better and/or fix before final 3.5 release.

I try to check this on 3.0.x and Aphas and B2.  Also see if I can confirm this on Windows.

Comment 20

10 years ago
Argh!  Now I can't reproduce this at all.  Marcia is still seeing it occasionally in B4 with google maps.  I want to check a trace now that it is not crashing and see what path it takes during printing.  But I won't have time for that until next week.

Comment 21

10 years ago
timr, copy this entire bug into http://konigsberg.mozilla.org/crash-stats.html and you'll understand.
Tim, were you able to reproduce the crashes meanwhile?

Comment 23

9 years ago
So, I'm sticking this command here for my reference:

perl -e 'use File::Glob ":glob";@frameworks = bsd_glob("/Library/Printers/*/Frameworks/*/Versions/*/Resources/*plist"); foreach my $framework (@frameworks) { $framework =~ s/\.plist$//; @args = qw(/usr/bin/defaults read); push @args, $framework, "CFBundleShortVersionString"; $framework =~ s{^.*/([^/]+)\.framework}{$1}; $framework =~ s{/Versions/([^/]+)/Resources/}{ $1 }; print "$framework: "; system(@args);}' 2>&1 |grep -v 'defaults\['|grep -v 'domain/default'

It'd be vaguely useful to me for a bit if people (not more than 5) would run that and "add an attachment <https://bugzilla.mozilla.org/attachment.cgi?bugid=461355&action=enter>" here containing the output.
Created attachment 399337 [details]
Output from Comment 23

I ran this on a 10.6 machine.
I can also reproduce this on my 10.5 machine by trying to print to the Lab printer which is an HP printer - using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2b1) Gecko/20091014 Firefox/3.6b1.
(In reply to comment #25)
> I can also reproduce this on my 10.5 machine by trying to print to the Lab
> printer which is an HP printer - using Mozilla/5.0 (Macintosh; U; Intel Mac OS
> X 10.5; en-US; rv:1.9.2b1) Gecko/20091014 Firefox/3.6b1.

Clint, could you help Marcia to run a session with gdb? Would be nice to have a full stack from a debug build.
I was just able to crash again today so if someone can help me with debugging this we can make the print experience much better on Mac.
(Reporter)

Updated

9 years ago
Summary: Crash in [HPSmartPrint@0xe1ef] after opening print dialog and canceling → Crash in [ HPSmartPrint@0xe1ef ] after opening print dialog and canceling

Updated

9 years ago
Summary: Crash in [ HPSmartPrint@0xe1ef ] after opening print dialog and canceling → Crash in [@ HPSmartPrint@0xe1ef ] after opening print dialog and canceling
Marcia, how often you can reproduce it? If it's only once a month or so we would have a hard time to debug this crash. But if you have some steps to reliable reproduce the crash we could find some time this week.
It turns out I had better luck reproducing Bug 525277 even though the STR seem similar, and added GDB trace to that bug.
From the crash-stats data I just reviewed it appears 59 people have hit this crash in 3.6, and it ranks as the #49 Mac crash overall right now.

Updated

8 years ago
Duplicate of this bug: 554286
(Assignee)

Updated

7 years ago
Crash Signature: [@ HPSmartPrint@0xe1ef ]

Comment 32

7 years ago
This looks to be only in 3.6.x. Resolving as Works For Me.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Issue is Resolved - removing QA-Wanted Keywords - QA-Wanted query clean-up task
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.