TM: X86_64 - error: cast from 'int*' to 'int32_t' loses precision nanojit/LIR.cpp

RESOLVED DUPLICATE of bug 494639

Status

()

Core
JavaScript Engine
--
major
RESOLVED DUPLICATE of bug 494639
9 years ago
9 years ago

People

(Reporter: bc, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
tracemonkey repo/mac os x:

g++ -o Linux_All_OPT.OBJ/nanojit/LIR.o -c -Wall -Wno-format -MMD -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE -DHAVE_LOCALTIME_R -DLINUX -DAVMPLUS_AMD64 -DAVMPLUS_64BIT -DAVMPLUS_UNIX -DAVMPLUS_LINUX -DHAVE_VA_COPY -DVA_COPY=va_copy -DPIC -fPIC  -UDEBUG -DNDEBUG -UDEBUG_bclary -DJS_TRACER -DFEATURE_NANOJIT -DEDITLINE -Inanojit -I. -ILinux_All_OPT.OBJ  -Os -fstrict-aliasing -fno-exceptions -fno-rtti -Wstrict-aliasing=2 nanojit/LIR.cpp
nanojit/LIR.cpp: In member function 'int32_t nanojit::LirBuffer::byteCount()':
nanojit/LIR.cpp:173: error: cast from 'nanojit::LIns*' to 'int32_t' loses precision
nanojit/LIR.cpp:173: error: cast from 'int*' to 'int32_t' loses precision
make[1]: *** [Linux_All_OPT.OBJ/nanojit/LIR.o] Error 1
Flags: in-testsuite-
Flags: in-litmus-
(Reporter)

Comment 1

9 years ago
this was for 64bit linux and not mac os x. sorry.
OS: Mac OS X → Linux
Hardware: Macintosh → PC
Summary: TM: error: cast from 'int*' to 'int32_t' loses precision nanojit/LIR.cpp → TM: X86_64 - error: cast from 'int*' to 'int32_t' loses precision nanojit/LIR.cpp
The patch for bug 494639 converted a lot of pointer arithmetic to byte arithmetic, and removed the int32_t casts in byteCount() in the process.

I'll mark this as a dup of bug 494639, someone please change if that's not appropriate.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 494639
You need to log in before you can comment on or make changes to this bug.