Menulists don't size properly until they have been opened

RESOLVED FIXED

Status

()

Core
XUL
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: neil@parkwaycc.co.uk, Assigned: Neil Deakin)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Bug #450990 added treeitem and menulist to the list of tags for which content should be lazily generated. Unforunately menulists need their first level to be generated so that they can size to their popup.
(Reporter)

Comment 1

10 years ago
Created attachment 344538 [details] [diff] [review]
Patch that Enn gave me over IRC

...which I have verified seems to resolve the problem.
Attachment #344538 - Flags: superreview?(bzbarsky)
Attachment #344538 - Flags: review+
Attachment #344538 - Flags: superreview?(bzbarsky) → superreview+
(Assignee)

Comment 2

10 years ago
treeitems were also not generated lazily this way I think. Would this be something that could cause a problem also?
(Reporter)

Comment 3

10 years ago
I think my summary may have been incorrect; what may have happened was that the old code would always generate menulists because they were the root node.
(Reporter)

Comment 4

10 years ago
As stefanh pointed out on IRC this also affects our charset menus.
(Reporter)

Comment 5

10 years ago
I mean menulists of course; we have real charset menus too.
(Assignee)

Comment 6

10 years ago
Is there more to do here?
(Reporter)

Comment 7

10 years ago
I wanted to give you the chance to check the patch in as it was your idea.
(Reporter)

Comment 8

10 years ago
Pushed changeset 157abfbcb96e to mozilla-central.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
sdwilsh backed this out as http://hg.mozilla.org/mozilla-central/rev/8b08744c500c because it was checked in while the tree was closed.  --> Reopening
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 10

10 years ago
f923f7a759e2
Status: REOPENED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.