Firefox random browser "time-out" & not ending browser properly not clearing from WIN Processes

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: vsardavids, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.17) Gecko/20080829 SeaMonkey/1.1.12
Build Identifier: http://www.mozilla.com/en-US/

Using Vista Ultimate with 2GB memory, 300GB HDD, the latest version of Firefox.
 
There are number of problems, randomly the Firefox v. 3.0.3 will time out and I can not go to any other web site.... does not respond when creating a new tab and entering a url address, not even from the current tab. I have no choice but to close the Firefox. If I close it it gives me the following massage and I have no choice but to restart the computer. <"Firefox is already running, but is not responding. To open a new window, you must close the existing Firefox process, or restart the system">

The other problem is when... doing a normal web browsing, while Firefox is busy loading a web site, if I close the Firefox... I can not run firefox again.... every time that I try to do rung the program. I receive the following massage... "Firefox is already running, but is not responding. To open a new window, you must close the existing Firefox process, or restart the system" I have no other Firefox running... so I try to end Firefox using the windows  Processes under the Windows Task Manager... which is the only place where I can see firefox.exe running... no matter what I do I can not end the Process by the number of times that I try to end the process <it just doesn't go away>. 

The only option that I have is no restart the computer... I which problem comes up number of times and its getting annoying...

I'm guessing that the new browser has some kind of memory bug when it comes to Vista Ultimate

Reproducible: Always

Steps to Reproduce:
1.Opening the browser going through couple of urls
2.leaving the browser running for couple of hours idle 
3. or while working on loading web site, I close the broswer
4. it gives me that following massage and I have no choice but to restart my computer

"Firefox is already running, but is not responding. To open a new window, you must close the existing Firefox process, or restart the system" 
Actual Results:  
"Firefox is already running, but is not responding. To open a new window, you must close the existing Firefox process, or restart the system" 

forced to restart... ending the process under windows task manager is useless... firefox.exe does not end, firefox.exe does not go away

Expected Results:  
end firefox completely so that I can open up a new firebox browser.... instead of restarting my computer 

I HOPE THIS PROBLEM GETS FIXED BY THE MOZILLA PEOPLE.

the browser "times out" or I close it and after that I get the following error massage... READ DETAILS BOX FOR MORE IN DEPT ERROR INFO.
"Firefox is already running, but is not responding. To open a new window, you must close the existing Firefox process, or restart the system" 

I think... but don't quote me on this..... but i think Firefox 3.0.3 has some kind of memory issue when it comes to Windows Vista Ultimate edition.... I don't know how many people are using Vista Ultimate are are experiencing similar problem....
You must be always able to kill Firefox with the windows taskmanager.
If you can't do that then you have a system issue and Firefox hangs somewhere in some kernel code and that is not Firefox fault because Firefox doesn't install any kernel mode drivers.
I guess that you are using a third-party and broken Firewall or Anti-Virus Software and that driver breaks Firefox. Just disabling this software would not help, you must remove the faulty driver and that means you have to uninstall the third-party Firewall or AV Software. The windows Firewall should be fine.
There is no difference for normal software between vista home and vista ultimate. The difference is basically additional applications and some other additional features.

I can not see how this should be a bug in Firefox itself and it works for me.
If you need help then please don't use bugzilla, use http://support.mozilla.com
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.