bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

after confirming automatic form capture, browser crashes

VERIFIED DUPLICATE of bug 46095

Status

()

Toolkit
Form Manager
P3
normal
VERIFIED DUPLICATE of bug 46095
18 years ago
10 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
found this using mozilla opt build on winnt, 2000.07.21.08.

steps to repro:
0. make sure the formfill pref is turned on.
1. go to the interview page (url above).
2. fill in the prefix, first name, last name, 1st address line, city and state.
3. scroll to the bottom of the page.
4. click the "save" button.
5. the "do you want to save this form data" confirm dialog should appear; click
OK.

result: mozilla crashes.

cc'ing neeting since she was the last person to touch nsHTTPChannel.cpp. the
other files haven't been touched in some time.

Talkback Incident ID 14595340 

nsHTTPChannel::ResponseCompleted
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp, line
1770] 
nsHTTPServerListener::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPResponseListener.cpp,
line 722] 
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line
302] 
nsStreamListenerEvent::HandlePLEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line
106] 
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 588] 
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 547] 
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1045] 
USER32.dll + 0x1820 (0x77e71820)

Comment 1

18 years ago
I think this is Bug 46095, which affected that particular build and is since
fixed.

*** This bug has been marked as a duplicate of 46095 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

18 years ago
thanks jerry! will vrfy when i get a more recent spin...
(Reporter)

Comment 3

18 years ago
[gah, i got your name wrong, Jeffrey --my apologies!]
(Reporter)

Comment 4

18 years ago
vrfy dup.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: bugzilla → form.manager
You need to log in before you can comment on or make changes to this bug.