TM: Some pages that were open during startup behave as if TM were disabled

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: claudio.s.martinez, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081023 Minefield/3.1b2pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b2pre) Gecko/20081023 Minefield/3.1b2pre

This (http://www.craftymind.com/factory/guimark/GUIMark_HTML4.html) browser benchmark runs wonderfully with TM enabled. I'm getting around 45fps vs 3-4 fps when it's disabled. 

However, if I close the browser (without closing the tab) and restart it, the benchmark runs sluggish. If I close the tab and paste the URL again it's still sluggish. The only way to make it work again is to close the tab, restart Minefield and then reopen that site.



Reproducible: Always

Steps to Reproduce:
1.Enable Tracemonkey and make sure Firefox is saving current tabs.
2.Go to http://www.craftymind.com/factory/guimark/GUIMark_HTML4.html and check the frames per second on the benchmark (should be fast, around 40fps).
3.Close the browser.
4.Open the browser and check the frames per second (should be slow, around 2fps).
Actual Results:  
The benchmark shows poor performance.

Expected Results:  
The benchmark should be as fast as it was on step 2.


This happens on a nightly build I downloaded 10/23/2008. Haven't tested other versions.

This only happens on Linux. I couldn't reproduce this on the windows version (tested through VirtualBox).

I have these (http://www.nvnews.net/vbulletin/showthread.php?t=118088) tweaks applied otherwise this test runs very slow always.

Updated

10 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk
(Reporter)

Comment 1

10 years ago
I cannot reproduce this anymore. 

Upgraded my OS to Ubuntu 8.10 and I'm using a snapshot from 08/nov.

Comment 2

10 years ago
no change with/without jit
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.