Saved form data is missing when opened in a new Tab with CTRL held down

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
10 years ago
9 years ago

People

(Reporter: verkuild, Unassigned)

Tracking

3.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3

If a URL is opened in a new Tab (by clicking a link w/CTRL held) that has saved form data fields, the data is missing UNTIL focus is shifted away from the active Tab and then back to it. Once that is done the form data is visible.
See steps below:


Reproducible: Always

Steps to Reproduce:
1. Go to link given above, open in new Tab by holding down CTRL.
2. Hit down arrow. The list of email address which has been entered there before should show. Nothing shows at this point.
3. Use CTRL-TAB and SHIFT-CTRL-TAB to move focus away from and back to new tab.
4. Hit down arrow again. Now the full list of email address shows.

Actual Results:  
1. The saved form data does NOT show.

Expected Results:  
1. Saved form data should show in fields opened in a new tab

1. This only happens if CTRL CLICK or LEFT CLICK, Open Link in New Tab is used to open the link in a new Tab.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
Confirmed on Vista using 3.0.1 and 3.0.3, when the preference to open a link in a new tab on the foreground is enabled.

I filled out several dummy usernames/passwords first.

It's not necessary to shift to another tab to change focus. Just clicking outside the email address field, for example, and clicking back inside the field will toggle the focus and show you the entries with arrow-down.

If you have the preference set to open links in tabs in the background, you don't see this problem. You are forced to focus on the email field before you can arrow-down.

Attaching PM debug logging info.
Created attachment 344647 [details]
debug logging enabled for password manager
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

9 years ago
This bug seems to have been fixed starting in release 3.5.2. I checked it again in 3.5.3 and it's also working correctly there.

Big Thanks to whoever took care of this one!
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
WFM since we don't know which patch has fixed it.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.