If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Seamonkey processes continue after closing the browser

RESOLVED WORKSFORME

Status

SeaMonkey
OS Integration
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: mhr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday0420])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1b1pre) Gecko/20080924175508 SeaMonkey/2.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1b1pre) Gecko/20080924175508 SeaMonkey/2.0a1

Whenever I exit the Seamonkey browser, three or four of its processes continue running (or hang) and never exit.  To restart the browser, I have to kill those processes and try again, and when I kill them, I get the "report a bug" window.

Reproducible: Always

Steps to Reproduce:
1. Start up Seamonkey
2. Exit Seamonkey

Actual Results:  
Browser exits but cannot be restarted because processes are still running.

Expected Results:  
Browser exits completely.
When you start SeaMonkey in the morning, it should not start "three or four" processes, at least not with the same name. On Linux, "seamonkey" is a script which launches "run-mozilla.sh", another script, which launches "seamonkey-bin", the binary executable which does the bulk of the work.

To close SeaMonkey, either hit Ctrl+Q or click File => Quit, then *wait* for it to terminate. If you have several tabs open, the browser may ask you (even if you hit Ctrl-Q or clicked File => Quit in the mailer) whether you're sure you want to close all tabs, so you should bring the browser window into focus to make sure it isn't waiting on your reply. Then, even after the last SeaMonkey window disppears, it may take some time (seconds or minutes depending on how many tabs you have open etc.) before the program actually terminates. What I recommend is to have (on Linux) ksysguard or gnome-system-monitor running (or the Task Manager on Windows, etc.): then you'll see a sharp drop in CPU and memory use when the program actually terminates (and its process will also disappear from the processes list, of course). "ps -lC seamonkey-bin" (typed at the shell prompt, without the quotes of course) will confirm that it has stopped running.
Version: unspecified → Trunk
(Reporter)

Comment 2

9 years ago
I am familiar with how seamonkey works, at least at the process level - I have been an avid fan and user since seamonkey appeared as a replacement/improvement for Netscape Navigator, and I've never looked back.  (And I am not offended by the kid glove treatment, but it's not required. :-)

I am aware of the ways in which seamonkey can be closed, and the above problem does not, in fact, occur every time (rats! but thank you guys, too!).

Last night, I was using seamonkey to browse around YouTube looking at various music and other videos, with two tabs open for a fair amount of that time.  When I exited, I didn't even think about checking the processes.

However, this morning, when I tried to start up seamonkey again, the following processes were still running (this is 8-10 hours later):

seamonkey
seamonkey-sh
seamonkey-bin
seamonkey-bin

That is not a typo - there were two seamonkey-bin processes still running.  Unfortunately, I forgot to send in a screen shot of the lines, and I was using a 'ps -ef | grep seamonkey' command, but I can send those in later today if you still are interested.

Tell me what more you need - should I attach to the seamonkey-bin processes and get stack traces next time this happens? (duh...)  Anything else?

Thanks for all your work.
Hm. I've never seen _two_ "seamonkey-bin" processes together with only _one_ "seamonkey" process; nor have I ever seen a "seamonkey-sh" process on this Linux system (using SeaMonkey distributions downloaded straight from Mozilla). What I've seen, as said before, is the following process tree: seamonkey => run-mozilla.sh => seamonkey-bin. Could you follow the processes tree back from those seamonkey* processes to their parents, their parents' parents, etc.? (Use the --pid argument of "ps -l", with a comma-separated list as the parameter, recursively adding the PPID values, not including 1 which is always init).

What I have seen sometimes at startup or shutdown, but not at other times, is a SeaMonkey hang together with a lot of CPU time being consumed by the FAM daemon (process name "famd"). That's bug 416745; the only "solution" I've found in that case is to use

   /etc/init.d/fam restart

from a root shell, then kill -15 on the seamonkey-bin process (I only see one) and restart SeaMonkey it in the usual way.

As for stack traces, if you know how to get them from a hang, they might (or might not) be useful. If you get one, attach it to this bug, either as a plaintext attachment or by pasting it into a comment.
P.S. No spaces in the comma-separated list (maybe you already know, but it does no harm to repeat it).
Build identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.9) Gecko/20100317 SeaMonkey/2.0.4

WORKSFORME

I cannot reproduce this behaviour.  Reporter, if this is still reproducible on Seamonkey 2.0.4, please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: General → OS Integration
QA Contact: general → os-integration
Resolution: --- → WORKSFORME
Whiteboard: [bugday0420]
You need to log in before you can comment on or make changes to this bug.