Closed Bug 461673 Opened 13 years ago Closed 10 years ago

Undo in find bar doesn't properly enable/disable toolbar buttons

Categories

(Toolkit :: Find Toolbar, defect)

defect
Not set
minor

Tracking

()

RESOLVED FIXED
mozilla9

People

(Reporter: crazy-eye-bugzilla, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.0.3) Gecko/2008092417 Firefox/3.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.1b1) Gecko/20081007 Firefox/3.1b1

After undo operation Next/Prev buttons may be enabled when the input field is empty and vice versa.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox, open blank page
2. Press Ctrl+F to open find bar
3. Type "abcd", then delete it using backspace and type "qwerty"
4. Press Ctrl+Z. Textbox is clear now
5. Press Ctrl+Z again. It's "abcd" here again.
Actual Results:  
After step 4 (when textbox is empty) toolbar buttons are still enabled.
After step 5 (when textbox contains "abcd") toolbar buttons are disabled.

Expected Results:  
After step 4 (when textbox is empty) toolbar buttons should become disabled.
After step 5 (when textbox contains "abcd") toolbar buttons should be enabled again.

After step 4 if you press Next button they become disabled. If you press Ctrl+Z now textbox will contain "abcd" but toolbar will still be disabled.

Reproducible in Firefox 2.0, 3.0 and 3.1b1

Workaround: after field is somehow changed (for example, last letter is deleted) findbar becomes enabled.
Confirmed on linux on trunk.
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
Depends on: 318065
Duplicate of this bug: 570415
This should be fixed by the landing of bug 318065 on mozilla-central (http://hg.mozilla.org/mozilla-central/rev/170e2522e530)
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla9
You need to log in before you can comment on or make changes to this bug.